summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2021-01-06 04:04:15 +0100
committerGitHub <noreply@github.com>2021-01-06 04:04:15 +0100
commitdc02b03c4abd9878abce75e26bec153382835c6b (patch)
treedf50002a188b9a65bf2cbd999a394273d0465666 /src/core/CMakeLists.txt
parentMerge pull request #5289 from ReinUsesLisp/vulkan-device (diff)
parentcore: Enforce C4715 (not all control paths return a value) (diff)
downloadyuzu-dc02b03c4abd9878abce75e26bec153382835c6b.tar
yuzu-dc02b03c4abd9878abce75e26bec153382835c6b.tar.gz
yuzu-dc02b03c4abd9878abce75e26bec153382835c6b.tar.bz2
yuzu-dc02b03c4abd9878abce75e26bec153382835c6b.tar.lz
yuzu-dc02b03c4abd9878abce75e26bec153382835c6b.tar.xz
yuzu-dc02b03c4abd9878abce75e26bec153382835c6b.tar.zst
yuzu-dc02b03c4abd9878abce75e26bec153382835c6b.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 01f3e9419..893df433a 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -635,6 +635,8 @@ if (MSVC)
/we4267
# 'context' : truncation from 'type1' to 'type2'
/we4305
+ # 'function' : not all control paths return a value
+ /we4715
)
else()
target_compile_options(core PRIVATE