summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2018-10-16 03:33:32 +0200
committerGitHub <noreply@github.com>2018-10-16 03:33:32 +0200
commit548958bcafa572fdfbb147b1bd590c02f9bb4b40 (patch)
tree0e6b51ffb96eeaa0873b5f47994aaf0959925bc4 /src/core/CMakeLists.txt
parentMerge pull request #1487 from lioncash/maybe-unused (diff)
parentcore/CMakeLists: Make all web_service-related libraries private (diff)
downloadyuzu-548958bcafa572fdfbb147b1bd590c02f9bb4b40.tar
yuzu-548958bcafa572fdfbb147b1bd590c02f9bb4b40.tar.gz
yuzu-548958bcafa572fdfbb147b1bd590c02f9bb4b40.tar.bz2
yuzu-548958bcafa572fdfbb147b1bd590c02f9bb4b40.tar.lz
yuzu-548958bcafa572fdfbb147b1bd590c02f9bb4b40.tar.xz
yuzu-548958bcafa572fdfbb147b1bd590c02f9bb4b40.tar.zst
yuzu-548958bcafa572fdfbb147b1bd590c02f9bb4b40.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 4fddaafd1..78986deb5 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -400,8 +400,8 @@ create_target_directory_groups(core)
target_link_libraries(core PUBLIC common PRIVATE audio_core video_core)
target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt lz4_static mbedtls opus unicorn open_source_archives)
if (ENABLE_WEB_SERVICE)
- add_definitions(-DENABLE_WEB_SERVICE)
- target_link_libraries(core PUBLIC json-headers web_service)
+ target_compile_definitions(core PRIVATE -DENABLE_WEB_SERVICE)
+ target_link_libraries(core PRIVATE web_service)
endif()
if (ARCHITECTURE_x86_64)