summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 9cfb9b1c8..3ba3afa70 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -17,7 +17,15 @@ set(SRCS core.cpp
elf/elf_reader.cpp
file_sys/directory_file_system.cpp
file_sys/meta_file_system.cpp
+ hle/hle.cpp
+ hle/syscall.cpp
+ hle/service/apt.cpp
+ hle/service/gsp.cpp
+ hle/service/hid.cpp
+ hle/service/service.cpp
+ hle/service/srv.cpp
hw/hw.cpp
- hw/hw_lcd.cpp)
+ hw/lcd.cpp
+ hw/ndma.cpp)
add_library(core STATIC ${SRCS})