summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorShizZy <shizzy@6bit.net>2014-04-23 00:35:40 +0200
committerShizZy <shizzy@6bit.net>2014-04-23 00:35:40 +0200
commit5c89324809f3753e143638acee1168d98ff7db6c (patch)
treedb2df30e5ad3e627e07d1802a0b6156ba1b1948c /src/core/CMakeLists.txt
parentRe-enable toggling window mode. (diff)
downloadyuzu-5c89324809f3753e143638acee1168d98ff7db6c.tar
yuzu-5c89324809f3753e143638acee1168d98ff7db6c.tar.gz
yuzu-5c89324809f3753e143638acee1168d98ff7db6c.tar.bz2
yuzu-5c89324809f3753e143638acee1168d98ff7db6c.tar.lz
yuzu-5c89324809f3753e143638acee1168d98ff7db6c.tar.xz
yuzu-5c89324809f3753e143638acee1168d98ff7db6c.tar.zst
yuzu-5c89324809f3753e143638acee1168d98ff7db6c.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 9cfb9b1c8..3ba3afa70 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -17,7 +17,15 @@ set(SRCS core.cpp
elf/elf_reader.cpp
file_sys/directory_file_system.cpp
file_sys/meta_file_system.cpp
+ hle/hle.cpp
+ hle/syscall.cpp
+ hle/service/apt.cpp
+ hle/service/gsp.cpp
+ hle/service/hid.cpp
+ hle/service/service.cpp
+ hle/service/srv.cpp
hw/hw.cpp
- hw/hw_lcd.cpp)
+ hw/lcd.cpp
+ hw/ndma.cpp)
add_library(core STATIC ${SRCS})