summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index de945fa70..65bbf4818 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -60,8 +60,12 @@ add_library(core STATIC
file_sys/fs_path_utility.h
file_sys/fs_save_data_types.h
file_sys/fs_string_util.h
+ file_sys/fsa/fs_i_directory.h
+ file_sys/fsa/fs_i_file.h
+ file_sys/fsa/fs_i_filesystem.h
file_sys/fsmitm_romfsbuild.cpp
file_sys/fsmitm_romfsbuild.h
+ file_sys/fssrv/fssrv_sf_path.h
file_sys/fssystem/fs_i_storage.h
file_sys/fssystem/fs_types.h
file_sys/fssystem/fssystem_aes_ctr_counter_extended_storage.cpp
@@ -544,6 +548,16 @@ add_library(core STATIC
hle/service/btdrv/btdrv.h
hle/service/btm/btm.cpp
hle/service/btm/btm.h
+ hle/service/btm/btm_debug.cpp
+ hle/service/btm/btm_debug.h
+ hle/service/btm/btm_system.cpp
+ hle/service/btm/btm_system.h
+ hle/service/btm/btm_system_core.cpp
+ hle/service/btm/btm_system_core.h
+ hle/service/btm/btm_user.cpp
+ hle/service/btm/btm_user.h
+ hle/service/btm/btm_user_core.cpp
+ hle/service/btm/btm_user_core.h
hle/service/caps/caps.cpp
hle/service/caps/caps.h
hle/service/caps/caps_a.cpp
@@ -886,6 +900,21 @@ add_library(core STATIC
hle/service/pm/pm.h
hle/service/prepo/prepo.cpp
hle/service/prepo/prepo.h
+ hle/service/psc/ovln/ovln_types.h
+ hle/service/psc/ovln/receiver_service.cpp
+ hle/service/psc/ovln/receiver_service.h
+ hle/service/psc/ovln/receiver.cpp
+ hle/service/psc/ovln/receiver.h
+ hle/service/psc/ovln/sender_service.cpp
+ hle/service/psc/ovln/sender_service.h
+ hle/service/psc/ovln/sender.cpp
+ hle/service/psc/ovln/sender.h
+ hle/service/psc/pm_control.cpp
+ hle/service/psc/pm_control.h
+ hle/service/psc/pm_module.cpp
+ hle/service/psc/pm_module.h
+ hle/service/psc/pm_service.cpp
+ hle/service/psc/pm_service.h
hle/service/psc/psc.cpp
hle/service/psc/psc.h
hle/service/psc/time/alarms.cpp