summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2024-02-23 17:34:06 +0100
committerGitHub <noreply@github.com>2024-02-23 17:34:06 +0100
commit0da6704fc2e45958ee2bf884128ce0ff5897ac1a (patch)
tree436e6adbf8dba2fdea6985b3e9b8cc24975d382e /src/core/CMakeLists.txt
parentMerge pull request #13121 from german77/clean-shortcut (diff)
parentAddress review comments (diff)
downloadyuzu-0da6704fc2e45958ee2bf884128ce0ff5897ac1a.tar
yuzu-0da6704fc2e45958ee2bf884128ce0ff5897ac1a.tar.gz
yuzu-0da6704fc2e45958ee2bf884128ce0ff5897ac1a.tar.bz2
yuzu-0da6704fc2e45958ee2bf884128ce0ff5897ac1a.tar.lz
yuzu-0da6704fc2e45958ee2bf884128ce0ff5897ac1a.tar.xz
yuzu-0da6704fc2e45958ee2bf884128ce0ff5897ac1a.tar.zst
yuzu-0da6704fc2e45958ee2bf884128ce0ff5897ac1a.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index a7b760fa2..65bbf4818 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -58,6 +58,7 @@ add_library(core STATIC
file_sys/fs_operate_range.h
file_sys/fs_path.h
file_sys/fs_path_utility.h
+ file_sys/fs_save_data_types.h
file_sys/fs_string_util.h
file_sys/fsa/fs_i_directory.h
file_sys/fsa/fs_i_file.h
@@ -599,6 +600,10 @@ add_library(core STATIC
hle/service/filesystem/fsp/fs_i_file.h
hle/service/filesystem/fsp/fs_i_filesystem.cpp
hle/service/filesystem/fsp/fs_i_filesystem.h
+ hle/service/filesystem/fsp/fs_i_multi_commit_manager.cpp
+ hle/service/filesystem/fsp/fs_i_multi_commit_manager.h
+ hle/service/filesystem/fsp/fs_i_save_data_info_reader.cpp
+ hle/service/filesystem/fsp/fs_i_save_data_info_reader.h
hle/service/filesystem/fsp/fs_i_storage.cpp
hle/service/filesystem/fsp/fs_i_storage.h
hle/service/filesystem/fsp/fsp_ldr.cpp
@@ -607,7 +612,7 @@ add_library(core STATIC
hle/service/filesystem/fsp/fsp_pr.h
hle/service/filesystem/fsp/fsp_srv.cpp
hle/service/filesystem/fsp/fsp_srv.h
- hle/service/filesystem/fsp/fsp_util.h
+ hle/service/filesystem/fsp/fsp_types.h
hle/service/filesystem/romfs_controller.cpp
hle/service/filesystem/romfs_controller.h
hle/service/filesystem/save_data_controller.cpp