summaryrefslogtreecommitdiffstats
path: root/externals/cryptopp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'externals/cryptopp/CMakeLists.txt')
-rw-r--r--externals/cryptopp/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/externals/cryptopp/CMakeLists.txt b/externals/cryptopp/CMakeLists.txt
index 864de18bb..8a626e44a 100644
--- a/externals/cryptopp/CMakeLists.txt
+++ b/externals/cryptopp/CMakeLists.txt
@@ -44,6 +44,11 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "Intel")
add_definitions(-wd68 -wd186 -wd279 -wd327 -wd161 -wd3180)
endif()
+if(MSVC)
+ # Disable C4390: empty controlled statement found: is this the intent?
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /wd4390")
+endif()
+
# Endianness
TEST_BIG_ENDIAN(IS_BIG_ENDIAN)
if(IS_BIG_ENDIAN)