summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorYuri Kunde Schlesner <yuriks@yuriks.net>2016-12-12 10:23:08 +0100
committerYuri Kunde Schlesner <yuriks@yuriks.net>2016-12-15 05:06:08 +0100
commitf4e98ecf3f3c144e0db2bc866e3fe5aac39f6ec9 (patch)
tree9cb61994f928e64ca68d07150fc2cb5719fe6457 /src/video_core/CMakeLists.txt
parentExternals: Add Xbyak (diff)
downloadyuzu-f4e98ecf3f3c144e0db2bc866e3fe5aac39f6ec9.tar
yuzu-f4e98ecf3f3c144e0db2bc866e3fe5aac39f6ec9.tar.gz
yuzu-f4e98ecf3f3c144e0db2bc866e3fe5aac39f6ec9.tar.bz2
yuzu-f4e98ecf3f3c144e0db2bc866e3fe5aac39f6ec9.tar.lz
yuzu-f4e98ecf3f3c144e0db2bc866e3fe5aac39f6ec9.tar.xz
yuzu-f4e98ecf3f3c144e0db2bc866e3fe5aac39f6ec9.tar.zst
yuzu-f4e98ecf3f3c144e0db2bc866e3fe5aac39f6ec9.zip
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index 581a37897..9aa446a8f 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -59,6 +59,9 @@ create_directory_groups(${SRCS} ${HEADERS})
add_library(video_core STATIC ${SRCS} ${HEADERS})
target_link_libraries(video_core glad)
+if (ARCHITECTURE_x86_64)
+ target_link_libraries(video_core xbyak)
+endif()
if (PNG_FOUND)
target_link_libraries(video_core ${PNG_LIBRARIES})