summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2023-06-28 18:53:17 +0200
committerGitHub <noreply@github.com>2023-06-28 18:53:17 +0200
commitb60b70e86d7c32b06a7580ddc286279a83587e11 (patch)
treeea6092ba2bda4b2f685926ba133faedd5c65fa57 /src/video_core/CMakeLists.txt
parentMerge pull request #10933 from merryhime/dunno (diff)
parentrenderer_vulkan: Prevent crashes when blitting depth stencil (diff)
downloadyuzu-b60b70e86d7c32b06a7580ddc286279a83587e11.tar
yuzu-b60b70e86d7c32b06a7580ddc286279a83587e11.tar.gz
yuzu-b60b70e86d7c32b06a7580ddc286279a83587e11.tar.bz2
yuzu-b60b70e86d7c32b06a7580ddc286279a83587e11.tar.lz
yuzu-b60b70e86d7c32b06a7580ddc286279a83587e11.tar.xz
yuzu-b60b70e86d7c32b06a7580ddc286279a83587e11.tar.zst
yuzu-b60b70e86d7c32b06a7580ddc286279a83587e11.zip
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index e9e6f278d..3b2fe01da 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -220,8 +220,8 @@ add_library(video_core STATIC
surface.h
texture_cache/accelerated_swizzle.cpp
texture_cache/accelerated_swizzle.h
- texture_cache/decode_bc4.cpp
- texture_cache/decode_bc4.h
+ texture_cache/decode_bc.cpp
+ texture_cache/decode_bc.h
texture_cache/descriptor_table.h
texture_cache/formatter.cpp
texture_cache/formatter.h
@@ -279,7 +279,7 @@ add_library(video_core STATIC
create_target_directory_groups(video_core)
target_link_libraries(video_core PUBLIC common core)
-target_link_libraries(video_core PUBLIC glad shader_recompiler stb)
+target_link_libraries(video_core PUBLIC glad shader_recompiler stb bc_decoder)
if (YUZU_USE_BUNDLED_FFMPEG AND NOT (WIN32 OR ANDROID))
add_dependencies(video_core ffmpeg-build)