summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorLC <mathew1800@gmail.com>2020-10-28 08:16:10 +0100
committerGitHub <noreply@github.com>2020-10-28 08:16:10 +0100
commit978e7897a3099178d94d3ab1b9ae4aff3a5bb2cd (patch)
treec74c7817c019da45060306b862c1a42e3f6249ec /src/video_core/CMakeLists.txt
parentMerge pull request #4847 from ReinUsesLisp/warn-move (diff)
parentvideo_core: Enforce -Werror=type-limits (diff)
downloadyuzu-978e7897a3099178d94d3ab1b9ae4aff3a5bb2cd.tar
yuzu-978e7897a3099178d94d3ab1b9ae4aff3a5bb2cd.tar.gz
yuzu-978e7897a3099178d94d3ab1b9ae4aff3a5bb2cd.tar.bz2
yuzu-978e7897a3099178d94d3ab1b9ae4aff3a5bb2cd.tar.lz
yuzu-978e7897a3099178d94d3ab1b9ae4aff3a5bb2cd.tar.xz
yuzu-978e7897a3099178d94d3ab1b9ae4aff3a5bb2cd.tar.zst
yuzu-978e7897a3099178d94d3ab1b9ae4aff3a5bb2cd.zip
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index 567084241..abcee2a1c 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -305,6 +305,7 @@ else()
-Werror=pessimizing-move
-Werror=redundant-move
-Werror=switch
+ -Werror=type-limits
-Werror=unused-variable
$<$<CXX_COMPILER_ID:GNU>:-Werror=class-memaccess>