summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2019-01-26 05:42:14 +0100
committerGitHub <noreply@github.com>2019-01-26 05:42:14 +0100
commit1f4ca1e841cd0b0427218d787efe10a3fa62df33 (patch)
tree00cc1743c6a6ba593e3b56897b13c2272a71d779 /src/video_core/CMakeLists.txt
parentMerge pull request #2054 from bunnei/scope-context-refactor (diff)
parentshader_ir: Fixup clang build (diff)
downloadyuzu-1f4ca1e841cd0b0427218d787efe10a3fa62df33.tar
yuzu-1f4ca1e841cd0b0427218d787efe10a3fa62df33.tar.gz
yuzu-1f4ca1e841cd0b0427218d787efe10a3fa62df33.tar.bz2
yuzu-1f4ca1e841cd0b0427218d787efe10a3fa62df33.tar.lz
yuzu-1f4ca1e841cd0b0427218d787efe10a3fa62df33.tar.xz
yuzu-1f4ca1e841cd0b0427218d787efe10a3fa62df33.tar.zst
yuzu-1f4ca1e841cd0b0427218d787efe10a3fa62df33.zip
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index 327db68a5..509ca117a 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -59,6 +59,34 @@ add_library(video_core STATIC
renderer_opengl/renderer_opengl.h
renderer_opengl/utils.cpp
renderer_opengl/utils.h
+ shader/decode/arithmetic.cpp
+ shader/decode/arithmetic_immediate.cpp
+ shader/decode/bfe.cpp
+ shader/decode/bfi.cpp
+ shader/decode/shift.cpp
+ shader/decode/arithmetic_integer.cpp
+ shader/decode/arithmetic_integer_immediate.cpp
+ shader/decode/arithmetic_half.cpp
+ shader/decode/arithmetic_half_immediate.cpp
+ shader/decode/ffma.cpp
+ shader/decode/hfma2.cpp
+ shader/decode/conversion.cpp
+ shader/decode/memory.cpp
+ shader/decode/float_set_predicate.cpp
+ shader/decode/integer_set_predicate.cpp
+ shader/decode/half_set_predicate.cpp
+ shader/decode/predicate_set_register.cpp
+ shader/decode/predicate_set_predicate.cpp
+ shader/decode/register_set_predicate.cpp
+ shader/decode/float_set.cpp
+ shader/decode/integer_set.cpp
+ shader/decode/half_set.cpp
+ shader/decode/video.cpp
+ shader/decode/xmad.cpp
+ shader/decode/other.cpp
+ shader/decode.cpp
+ shader/shader_ir.cpp
+ shader/shader_ir.h
surface.cpp
surface.h
textures/astc.cpp