summaryrefslogtreecommitdiffstats
path: root/src/shader_recompiler/CMakeLists.txt
diff options
context:
space:
mode:
authorMorph <39850852+Morph1984@users.noreply.github.com>2022-10-21 08:34:06 +0200
committerMorph <39850852+Morph1984@users.noreply.github.com>2022-10-22 21:02:04 +0200
commit93297d14d8fc5c8f73e8ccba5ca989590a453c05 (patch)
tree4b25f5ceda595051501136a7f3000e7ef989e1f1 /src/shader_recompiler/CMakeLists.txt
parentCMakeLists: Consolidate all unused warnings into -Wunused (diff)
downloadyuzu-93297d14d8fc5c8f73e8ccba5ca989590a453c05.tar
yuzu-93297d14d8fc5c8f73e8ccba5ca989590a453c05.tar.gz
yuzu-93297d14d8fc5c8f73e8ccba5ca989590a453c05.tar.bz2
yuzu-93297d14d8fc5c8f73e8ccba5ca989590a453c05.tar.lz
yuzu-93297d14d8fc5c8f73e8ccba5ca989590a453c05.tar.xz
yuzu-93297d14d8fc5c8f73e8ccba5ca989590a453c05.tar.zst
yuzu-93297d14d8fc5c8f73e8ccba5ca989590a453c05.zip
Diffstat (limited to 'src/shader_recompiler/CMakeLists.txt')
-rw-r--r--src/shader_recompiler/CMakeLists.txt10
1 files changed, 2 insertions, 8 deletions
diff --git a/src/shader_recompiler/CMakeLists.txt b/src/shader_recompiler/CMakeLists.txt
index af8e51fe8..cbc1daf77 100644
--- a/src/shader_recompiler/CMakeLists.txt
+++ b/src/shader_recompiler/CMakeLists.txt
@@ -242,23 +242,17 @@ if (MSVC)
target_compile_options(shader_recompiler PRIVATE
/W4
/WX
- /we4018 # 'expression' : signed/unsigned mismatch
+
+ /we4242 # 'identifier': conversion from 'type1' to 'type2', possible loss of data
/we4244 # 'argument' : conversion from 'type1' to 'type2', possible loss of data (floating-point)
/we4245 # 'conversion' : conversion from 'type1' to 'type2', signed/unsigned mismatch
/we4254 # 'operator': conversion from 'type1:field_bits' to 'type2:field_bits', possible loss of data
- /we4267 # 'var' : conversion from 'size_t' to 'type', possible loss of data
- /we4305 # 'context' : truncation from 'type1' to 'type2'
/we4800 # Implicit conversion from 'type' to bool. Possible information loss
/we4826 # Conversion from 'type1' to 'type2' is sign-extended. This may cause unexpected runtime behavior.
)
else()
target_compile_options(shader_recompiler PRIVATE
- -Werror
-Werror=conversion
- -Werror=ignored-qualifiers
- $<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-parameter>
- $<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-variable>
- -Werror=unused-variable
# Bracket depth determines maximum size of a fold expression in Clang since 9c9974c3ccb6.
# And this in turns limits the size of a std::array.