summaryrefslogtreecommitdiffstats
path: root/src/input_common/CMakeLists.txt
diff options
context:
space:
mode:
authorYuri Kunde Schlesner <yuriks@yuriks.net>2017-05-30 00:12:21 +0200
committerGitHub <noreply@github.com>2017-05-30 00:12:21 +0200
commita4f88c7d7c94107df6bfada31617ff553bb5e89e (patch)
treecb0d3adbbe115604051300ae451a22a4de751b27 /src/input_common/CMakeLists.txt
parentMerge pull request #2729 from yuriks/quaternion-fix (diff)
parentCMake: Re-organize root CMakeLists.txt file (diff)
downloadyuzu-a4f88c7d7c94107df6bfada31617ff553bb5e89e.tar
yuzu-a4f88c7d7c94107df6bfada31617ff553bb5e89e.tar.gz
yuzu-a4f88c7d7c94107df6bfada31617ff553bb5e89e.tar.bz2
yuzu-a4f88c7d7c94107df6bfada31617ff553bb5e89e.tar.lz
yuzu-a4f88c7d7c94107df6bfada31617ff553bb5e89e.tar.xz
yuzu-a4f88c7d7c94107df6bfada31617ff553bb5e89e.tar.zst
yuzu-a4f88c7d7c94107df6bfada31617ff553bb5e89e.zip
Diffstat (limited to 'src/input_common/CMakeLists.txt')
-rw-r--r--src/input_common/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/input_common/CMakeLists.txt b/src/input_common/CMakeLists.txt
index 5b306e42e..e3e36ada7 100644
--- a/src/input_common/CMakeLists.txt
+++ b/src/input_common/CMakeLists.txt
@@ -13,7 +13,6 @@ set(HEADERS
if(SDL2_FOUND)
set(SRCS ${SRCS} sdl/sdl.cpp)
set(HEADERS ${HEADERS} sdl/sdl.h)
- include_directories(${SDL2_INCLUDE_DIR})
endif()
create_directory_groups(${SRCS} ${HEADERS})
@@ -22,6 +21,6 @@ add_library(input_common STATIC ${SRCS} ${HEADERS})
target_link_libraries(input_common PUBLIC core PRIVATE common)
if(SDL2_FOUND)
- target_link_libraries(input_common PRIVATE ${SDL2_LIBRARY})
+ target_link_libraries(input_common PRIVATE SDL2)
target_compile_definitions(input_common PRIVATE HAVE_SDL2)
endif()