summaryrefslogtreecommitdiffstats
path: root/src/input_common/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2020-10-16 05:59:34 +0200
committerGitHub <noreply@github.com>2020-10-16 05:59:34 +0200
commit64f967fd4958abb5a02191a81e91fc8b33bcf4c5 (patch)
tree97a73da4871f006b39eafca3a881ae2ea42f206a /src/input_common/CMakeLists.txt
parentMerge pull request #4784 from bunnei/cancelbuffer (diff)
parentinput_common/CMakeLists: Make some warnings errors (diff)
downloadyuzu-64f967fd4958abb5a02191a81e91fc8b33bcf4c5.tar
yuzu-64f967fd4958abb5a02191a81e91fc8b33bcf4c5.tar.gz
yuzu-64f967fd4958abb5a02191a81e91fc8b33bcf4c5.tar.bz2
yuzu-64f967fd4958abb5a02191a81e91fc8b33bcf4c5.tar.lz
yuzu-64f967fd4958abb5a02191a81e91fc8b33bcf4c5.tar.xz
yuzu-64f967fd4958abb5a02191a81e91fc8b33bcf4c5.tar.zst
yuzu-64f967fd4958abb5a02191a81e91fc8b33bcf4c5.zip
Diffstat (limited to 'src/input_common/CMakeLists.txt')
-rw-r--r--src/input_common/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/input_common/CMakeLists.txt b/src/input_common/CMakeLists.txt
index c84685214..7b39a38c1 100644
--- a/src/input_common/CMakeLists.txt
+++ b/src/input_common/CMakeLists.txt
@@ -29,6 +29,35 @@ add_library(input_common STATIC
udp/udp.h
)
+if (MSVC)
+ target_compile_options(input_common PRIVATE
+ # 'expression' : signed/unsigned mismatch
+ /we4018
+ # 'argument' : conversion from 'type1' to 'type2', possible loss of data (floating-point)
+ /we4244
+ # 'conversion' : conversion from 'type1' to 'type2', signed/unsigned mismatch
+ /we4245
+ # 'operator': conversion from 'type1:field_bits' to 'type2:field_bits', possible loss of data
+ /we4254
+ # 'var' : conversion from 'size_t' to 'type', possible loss of data
+ /we4267
+ # 'context' : truncation from 'type1' to 'type2'
+ /we4305
+ )
+else()
+ target_compile_options(input_common PRIVATE
+ -Werror=conversion
+ -Werror=ignored-qualifiers
+ -Werror=implicit-fallthrough
+ -Werror=reorder
+ -Werror=shadow
+ -Werror=sign-compare
+ -Werror=unused-but-set-parameter
+ -Werror=unused-but-set-variable
+ -Werror=unused-variable
+ )
+endif()
+
if(SDL2_FOUND)
target_sources(input_common PRIVATE
sdl/sdl_impl.cpp