summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorMarkus Wick <markus@selfnet.de>2020-04-16 16:46:33 +0200
committerMarkus Wick <markus@selfnet.de>2020-04-16 16:46:33 +0200
commitfedf750e1b323cab927d08393783927a6db1e912 (patch)
tree13d9ea244610ad2bc5c1d717d688b7a725a6a9f7 /src/core/CMakeLists.txt
parentinput_common: Use the CMake target instead of the variable. (diff)
downloadyuzu-fedf750e1b323cab927d08393783927a6db1e912.tar
yuzu-fedf750e1b323cab927d08393783927a6db1e912.tar.gz
yuzu-fedf750e1b323cab927d08393783927a6db1e912.tar.bz2
yuzu-fedf750e1b323cab927d08393783927a6db1e912.tar.lz
yuzu-fedf750e1b323cab927d08393783927a6db1e912.tar.xz
yuzu-fedf750e1b323cab927d08393783927a6db1e912.tar.zst
yuzu-fedf750e1b323cab927d08393783927a6db1e912.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 66497a386..c15d9f52f 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -591,11 +591,8 @@ target_link_libraries(core PUBLIC common PRIVATE audio_core video_core)
target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt json-headers mbedtls opus unicorn)
if (YUZU_ENABLE_BOXCAT)
- get_directory_property(OPENSSL_LIBS
- DIRECTORY ${PROJECT_SOURCE_DIR}/externals/libressl
- DEFINITION OPENSSL_LIBS)
- target_compile_definitions(core PRIVATE -DCPPHTTPLIB_OPENSSL_SUPPORT -DYUZU_ENABLE_BOXCAT)
- target_link_libraries(core PRIVATE httplib json-headers ${OPENSSL_LIBS} zip)
+ target_compile_definitions(core PRIVATE -DYUZU_ENABLE_BOXCAT)
+ target_link_libraries(core PRIVATE httplib json-headers zip)
endif()
if (ENABLE_WEB_SERVICE)