summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2021-02-12 03:55:22 +0100
committerbunnei <bunneidev@gmail.com>2021-02-19 01:16:24 +0100
commitf7a008d77f8aa47baf4c874c508b38af4965a145 (patch)
tree3a11b865d5f49be8fa0588ee5187f1b6c12022fb /src/core/CMakeLists.txt
parenthle: kernel: memory: PageHeap: Migrate to KPageBitmap class. (diff)
downloadyuzu-f7a008d77f8aa47baf4c874c508b38af4965a145.tar
yuzu-f7a008d77f8aa47baf4c874c508b38af4965a145.tar.gz
yuzu-f7a008d77f8aa47baf4c874c508b38af4965a145.tar.bz2
yuzu-f7a008d77f8aa47baf4c874c508b38af4965a145.tar.lz
yuzu-f7a008d77f8aa47baf4c874c508b38af4965a145.tar.xz
yuzu-f7a008d77f8aa47baf4c874c508b38af4965a145.tar.zst
yuzu-f7a008d77f8aa47baf4c874c508b38af4965a145.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 6604bc2c5..8aad9cb41 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -182,6 +182,8 @@ add_library(core STATIC
hle/kernel/k_spin_lock.h
hle/kernel/k_synchronization_object.cpp
hle/kernel/k_synchronization_object.h
+ hle/kernel/k_system_control.cpp
+ hle/kernel/k_system_control.h
hle/kernel/k_thread.cpp
hle/kernel/k_thread.h
hle/kernel/k_thread_queue.h
@@ -204,8 +206,6 @@ add_library(core STATIC
hle/kernel/memory/page_table.cpp
hle/kernel/memory/page_table.h
hle/kernel/memory/slab_heap.h
- hle/kernel/memory/system_control.cpp
- hle/kernel/memory/system_control.h
hle/kernel/object.cpp
hle/kernel/object.h
hle/kernel/physical_core.cpp