summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorMorph <39850852+Morph1984@users.noreply.github.com>2022-05-27 02:08:21 +0200
committerMorph <39850852+Morph1984@users.noreply.github.com>2022-06-14 00:19:23 +0200
commitefc89c032b18d149308a1f8c1a371f503edb91d1 (patch)
treedafbdc3a20ad07f24ee92c4583e3e84ecf01ab02 /src/core/CMakeLists.txt
parentexternals: microprofile: Eliminate variable shadowing (diff)
downloadyuzu-efc89c032b18d149308a1f8c1a371f503edb91d1.tar
yuzu-efc89c032b18d149308a1f8c1a371f503edb91d1.tar.gz
yuzu-efc89c032b18d149308a1f8c1a371f503edb91d1.tar.bz2
yuzu-efc89c032b18d149308a1f8c1a371f503edb91d1.tar.lz
yuzu-efc89c032b18d149308a1f8c1a371f503edb91d1.tar.xz
yuzu-efc89c032b18d149308a1f8c1a371f503edb91d1.tar.zst
yuzu-efc89c032b18d149308a1f8c1a371f503edb91d1.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 2bd720f08..670410e75 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -743,16 +743,11 @@ if (MSVC)
/we4244 # 'conversion': conversion from 'type1' to 'type2', possible loss of data
/we4245 # 'conversion': conversion from 'type1' to 'type2', signed/unsigned mismatch
/we4254 # 'operator': conversion from 'type1:field_bits' to 'type2:field_bits', possible loss of data
- /we4456 # Declaration of 'identifier' hides previous local declaration
- /we4457 # Declaration of 'identifier' hides function parameter
- /we4458 # Declaration of 'identifier' hides class member
- /we4459 # Declaration of 'identifier' hides global declaration
)
else()
target_compile_options(core PRIVATE
-Werror=conversion
-Werror=ignored-qualifiers
- -Werror=shadow
$<$<CXX_COMPILER_ID:GNU>:-Werror=class-memaccess>
$<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-parameter>