summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Marcec <dmarcecguzman@gmail.com>2019-09-22 09:47:25 +0200
committerDavid Marcec <dmarcecguzman@gmail.com>2019-09-22 09:47:25 +0200
commitd961d5479e0246f217883b57bbfdd736610b642e (patch)
treedcdcfb617b1fa680eaa74cf1a96f872f259bba1b /src/core/CMakeLists.txt
parentMerge pull request #2535 from DarkLordZach/cheat-v2 (diff)
downloadyuzu-d961d5479e0246f217883b57bbfdd736610b642e.tar
yuzu-d961d5479e0246f217883b57bbfdd736610b642e.tar.gz
yuzu-d961d5479e0246f217883b57bbfdd736610b642e.tar.bz2
yuzu-d961d5479e0246f217883b57bbfdd736610b642e.tar.lz
yuzu-d961d5479e0246f217883b57bbfdd736610b642e.tar.xz
yuzu-d961d5479e0246f217883b57bbfdd736610b642e.tar.zst
yuzu-d961d5479e0246f217883b57bbfdd736610b642e.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt16
1 files changed, 1 insertions, 15 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 2deaf560c..a6b56c9c6 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -68,24 +68,10 @@ add_library(core STATIC
file_sys/sdmc_factory.h
file_sys/submission_package.cpp
file_sys/submission_package.h
- file_sys/system_archive/data/font_chinese_simplified.cpp
- file_sys/system_archive/data/font_chinese_simplified.h
- file_sys/system_archive/data/font_chinese_traditional.cpp
- file_sys/system_archive/data/font_chinese_traditional.h
- file_sys/system_archive/data/font_extended_chinese_simplified.cpp
- file_sys/system_archive/data/font_extended_chinese_simplified.h
- file_sys/system_archive/data/font_korean.cpp
- file_sys/system_archive/data/font_korean.h
- file_sys/system_archive/data/font_nintendo_extended.cpp
- file_sys/system_archive/data/font_nintendo_extended.h
- file_sys/system_archive/data/font_standard.cpp
- file_sys/system_archive/data/font_standard.h
file_sys/system_archive/mii_model.cpp
file_sys/system_archive/mii_model.h
file_sys/system_archive/ng_word.cpp
file_sys/system_archive/ng_word.h
- file_sys/system_archive/shared_font.cpp
- file_sys/system_archive/shared_font.h
file_sys/system_archive/system_archive.cpp
file_sys/system_archive/system_archive.h
file_sys/system_archive/system_version.cpp
@@ -512,7 +498,7 @@ add_library(core STATIC
create_target_directory_groups(core)
target_link_libraries(core PUBLIC common PRIVATE audio_core video_core)
-target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt json-headers mbedtls opus unicorn)
+target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt json-headers mbedtls opus unicorn open_source_archives)
if (ENABLE_WEB_SERVICE)
target_compile_definitions(core PRIVATE -DENABLE_WEB_SERVICE)
target_link_libraries(core PRIVATE web_service)