summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorZach Hilman <zachhilman@gmail.com>2019-07-06 00:49:52 +0200
committerZach Hilman <zachhilman@gmail.com>2019-10-13 19:46:10 +0200
commitd6d6a87bde05bc7bed48446708bd19cf0498af8a (patch)
tree76f744dc9c0377b394f4e336c4da17cf0039893a /src/core/CMakeLists.txt
parentMerge pull request #2910 from FearlessTobi/port-4930 (diff)
downloadyuzu-d6d6a87bde05bc7bed48446708bd19cf0498af8a.tar
yuzu-d6d6a87bde05bc7bed48446708bd19cf0498af8a.tar.gz
yuzu-d6d6a87bde05bc7bed48446708bd19cf0498af8a.tar.bz2
yuzu-d6d6a87bde05bc7bed48446708bd19cf0498af8a.tar.lz
yuzu-d6d6a87bde05bc7bed48446708bd19cf0498af8a.tar.xz
yuzu-d6d6a87bde05bc7bed48446708bd19cf0498af8a.tar.zst
yuzu-d6d6a87bde05bc7bed48446708bd19cf0498af8a.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 3b1d72cf9..4f6a87b0a 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -74,10 +74,24 @@ add_library(core STATIC
file_sys/sdmc_factory.h
file_sys/submission_package.cpp
file_sys/submission_package.h
+ file_sys/system_archive/data/font_chinese_simplified.cpp
+ file_sys/system_archive/data/font_chinese_simplified.h
+ file_sys/system_archive/data/font_chinese_traditional.cpp
+ file_sys/system_archive/data/font_chinese_traditional.h
+ file_sys/system_archive/data/font_extended_chinese_simplified.cpp
+ file_sys/system_archive/data/font_extended_chinese_simplified.h
+ file_sys/system_archive/data/font_korean.cpp
+ file_sys/system_archive/data/font_korean.h
+ file_sys/system_archive/data/font_nintendo_extended.cpp
+ file_sys/system_archive/data/font_nintendo_extended.h
+ file_sys/system_archive/data/font_standard.cpp
+ file_sys/system_archive/data/font_standard.h
file_sys/system_archive/mii_model.cpp
file_sys/system_archive/mii_model.h
file_sys/system_archive/ng_word.cpp
file_sys/system_archive/ng_word.h
+ file_sys/system_archive/shared_font.cpp
+ file_sys/system_archive/shared_font.h
file_sys/system_archive/system_archive.cpp
file_sys/system_archive/system_archive.h
file_sys/system_archive/system_version.cpp
@@ -511,7 +525,7 @@ add_library(core STATIC
create_target_directory_groups(core)
target_link_libraries(core PUBLIC common PRIVATE audio_core video_core)
-target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt json-headers mbedtls opus unicorn open_source_archives)
+target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt json-headers mbedtls opus unicorn)
if (YUZU_ENABLE_BOXCAT)
get_directory_property(OPENSSL_LIBS