summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGPUCode <geoster3d@gmail.com>2023-09-10 22:26:09 +0200
committerGPUCode <geoster3d@gmail.com>2023-09-14 15:37:41 +0200
commitc656105a6c6ce14ced695f8edb1864cbba4e66dd (patch)
tree65f998b067a4b01aac8841f11575214fe942fdfe /src/core/CMakeLists.txt
parentMerge pull request #11496 from liamwhite/ngc (diff)
downloadyuzu-c656105a6c6ce14ced695f8edb1864cbba4e66dd.tar
yuzu-c656105a6c6ce14ced695f8edb1864cbba4e66dd.tar.gz
yuzu-c656105a6c6ce14ced695f8edb1864cbba4e66dd.tar.bz2
yuzu-c656105a6c6ce14ced695f8edb1864cbba4e66dd.tar.lz
yuzu-c656105a6c6ce14ced695f8edb1864cbba4e66dd.tar.xz
yuzu-c656105a6c6ce14ced695f8edb1864cbba4e66dd.tar.zst
yuzu-c656105a6c6ce14ced695f8edb1864cbba4e66dd.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 6cd1a28f2..30d2f7df6 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -864,6 +864,8 @@ add_library(core STATIC
telemetry_session.h
tools/freezer.cpp
tools/freezer.h
+ tools/renderdoc.cpp
+ tools/renderdoc.h
)
if (MSVC)
@@ -879,6 +881,7 @@ else()
-Werror=conversion
-Wno-sign-conversion
+ -Wno-cast-function-type
$<$<CXX_COMPILER_ID:Clang>:-fsized-deallocation>
)
@@ -887,7 +890,7 @@ endif()
create_target_directory_groups(core)
target_link_libraries(core PUBLIC common PRIVATE audio_core network video_core nx_tzdb)
-target_link_libraries(core PUBLIC Boost::headers PRIVATE fmt::fmt nlohmann_json::nlohmann_json mbedtls Opus::opus)
+target_link_libraries(core PUBLIC Boost::headers PRIVATE fmt::fmt nlohmann_json::nlohmann_json mbedtls Opus::opus renderdoc)
if (MINGW)
target_link_libraries(core PRIVATE ${MSWSOCK_LIBRARY})
endif()