summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2018-08-16 05:11:58 +0200
committerGitHub <noreply@github.com>2018-08-16 05:11:58 +0200
commitc594ec341768a54dc2577c64fd15a6c0041456cd (patch)
tree3814f831fd8207598c342341e56997a0b3123cd0 /src/core/CMakeLists.txt
parentMerge pull request #1078 from lioncash/message (diff)
parentregistration: Various style and documentation improvements (diff)
downloadyuzu-c594ec341768a54dc2577c64fd15a6c0041456cd.tar
yuzu-c594ec341768a54dc2577c64fd15a6c0041456cd.tar.gz
yuzu-c594ec341768a54dc2577c64fd15a6c0041456cd.tar.bz2
yuzu-c594ec341768a54dc2577c64fd15a6c0041456cd.tar.lz
yuzu-c594ec341768a54dc2577c64fd15a6c0041456cd.tar.xz
yuzu-c594ec341768a54dc2577c64fd15a6c0041456cd.tar.zst
yuzu-c594ec341768a54dc2577c64fd15a6c0041456cd.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 0b0ae5ccc..67ad6109a 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -20,6 +20,8 @@ add_library(core STATIC
crypto/key_manager.h
crypto/ctr_encryption_layer.cpp
crypto/ctr_encryption_layer.h
+ file_sys/bis_factory.cpp
+ file_sys/bis_factory.h
file_sys/card_image.cpp
file_sys/card_image.h
file_sys/content_archive.cpp
@@ -29,10 +31,14 @@ add_library(core STATIC
file_sys/directory.h
file_sys/errors.h
file_sys/mode.h
+ file_sys/nca_metadata.cpp
+ file_sys/nca_metadata.h
file_sys/partition_filesystem.cpp
file_sys/partition_filesystem.h
file_sys/program_metadata.cpp
file_sys/program_metadata.h
+ file_sys/registered_cache.cpp
+ file_sys/registered_cache.h
file_sys/romfs.cpp
file_sys/romfs.h
file_sys/romfs_factory.cpp
@@ -43,6 +49,8 @@ add_library(core STATIC
file_sys/sdmc_factory.h
file_sys/vfs.cpp
file_sys/vfs.h
+ file_sys/vfs_concat.cpp
+ file_sys/vfs_concat.h
file_sys/vfs_offset.cpp
file_sys/vfs_offset.h
file_sys/vfs_real.cpp