summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2018-10-06 08:43:09 +0200
committerGitHub <noreply@github.com>2018-10-06 08:43:09 +0200
commitb8b90ce6e61329ebda226b9917ed961be3b80d1f (patch)
tree8e6b82419db7fb24eb5d8f06346a0a1228f9513c /src/core/CMakeLists.txt
parentMerge pull request #1447 from lioncash/mutex (diff)
parentReview comments - part 5 (diff)
downloadyuzu-b8b90ce6e61329ebda226b9917ed961be3b80d1f.tar
yuzu-b8b90ce6e61329ebda226b9917ed961be3b80d1f.tar.gz
yuzu-b8b90ce6e61329ebda226b9917ed961be3b80d1f.tar.bz2
yuzu-b8b90ce6e61329ebda226b9917ed961be3b80d1f.tar.lz
yuzu-b8b90ce6e61329ebda226b9917ed961be3b80d1f.tar.xz
yuzu-b8b90ce6e61329ebda226b9917ed961be3b80d1f.tar.zst
yuzu-b8b90ce6e61329ebda226b9917ed961be3b80d1f.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index a98dbb9ab..e4a676e91 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -396,6 +396,10 @@ create_target_directory_groups(core)
target_link_libraries(core PUBLIC common PRIVATE audio_core video_core)
target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt lz4_static mbedtls opus unicorn open_source_archives)
+if (ENABLE_WEB_SERVICE)
+ add_definitions(-DENABLE_WEB_SERVICE)
+ target_link_libraries(core PUBLIC json-headers web_service)
+endif()
if (ARCHITECTURE_x86_64)
target_sources(core PRIVATE