summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2021-04-10 09:02:52 +0200
committerGitHub <noreply@github.com>2021-04-10 09:02:52 +0200
commitb04877dd952d7da11647f16626952d7325e4e900 (patch)
treed097ebea3b24a2c815015c17e6c5fd89c69ce045 /src/core/CMakeLists.txt
parentMerge pull request #6171 from german77/services (diff)
parenthle: kernel: Breakup InitializeMemoryLayout. (diff)
downloadyuzu-b04877dd952d7da11647f16626952d7325e4e900.tar
yuzu-b04877dd952d7da11647f16626952d7325e4e900.tar.gz
yuzu-b04877dd952d7da11647f16626952d7325e4e900.tar.bz2
yuzu-b04877dd952d7da11647f16626952d7325e4e900.tar.lz
yuzu-b04877dd952d7da11647f16626952d7325e4e900.tar.xz
yuzu-b04877dd952d7da11647f16626952d7325e4e900.tar.zst
yuzu-b04877dd952d7da11647f16626952d7325e4e900.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 17f251c37..0c1f5b0c8 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -141,6 +141,9 @@ add_library(core STATIC
hardware_interrupt_manager.h
hle/ipc.h
hle/ipc_helpers.h
+ hle/kernel/board/nintendo/nx/k_system_control.cpp
+ hle/kernel/board/nintendo/nx/k_system_control.h
+ hle/kernel/board/nintendo/nx/secure_monitor.h
hle/kernel/client_port.cpp
hle/kernel/client_port.h
hle/kernel/client_session.cpp
@@ -169,9 +172,13 @@ add_library(core STATIC
hle/kernel/k_memory_block.h
hle/kernel/k_memory_block_manager.cpp
hle/kernel/k_memory_block_manager.h
+ hle/kernel/k_memory_layout.cpp
+ hle/kernel/k_memory_layout.board.nintendo_nx.cpp
hle/kernel/k_memory_layout.h
hle/kernel/k_memory_manager.cpp
hle/kernel/k_memory_manager.h
+ hle/kernel/k_memory_region.h
+ hle/kernel/k_memory_region_type.h
hle/kernel/k_page_bitmap.h
hle/kernel/k_page_heap.cpp
hle/kernel/k_page_heap.h
@@ -196,11 +203,11 @@ add_library(core STATIC
hle/kernel/k_spin_lock.h
hle/kernel/k_synchronization_object.cpp
hle/kernel/k_synchronization_object.h
- hle/kernel/k_system_control.cpp
hle/kernel/k_system_control.h
hle/kernel/k_thread.cpp
hle/kernel/k_thread.h
hle/kernel/k_thread_queue.h
+ hle/kernel/k_trace.h
hle/kernel/k_writable_event.cpp
hle/kernel/k_writable_event.h
hle/kernel/kernel.cpp