summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2020-11-07 07:39:05 +0100
committerGitHub <noreply@github.com>2020-11-07 07:39:05 +0100
commitaf477fb8c5f4b87223aafd8e970b02a472a8118b (patch)
treea0e65e441c260c28e70074f405e9a7bb196bfe44 /src/core/CMakeLists.txt
parentMerge pull request #4899 from lioncash/fiberimpl (diff)
parentcore: Remove usage of unicorn (diff)
downloadyuzu-af477fb8c5f4b87223aafd8e970b02a472a8118b.tar
yuzu-af477fb8c5f4b87223aafd8e970b02a472a8118b.tar.gz
yuzu-af477fb8c5f4b87223aafd8e970b02a472a8118b.tar.bz2
yuzu-af477fb8c5f4b87223aafd8e970b02a472a8118b.tar.lz
yuzu-af477fb8c5f4b87223aafd8e970b02a472a8118b.tar.xz
yuzu-af477fb8c5f4b87223aafd8e970b02a472a8118b.tar.zst
yuzu-af477fb8c5f4b87223aafd8e970b02a472a8118b.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 9a983e81d..a1d8dcfa5 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -13,8 +13,6 @@ add_library(core STATIC
arm/dynarmic/arm_exclusive_monitor.h
arm/exclusive_monitor.cpp
arm/exclusive_monitor.h
- arm/unicorn/arm_unicorn.cpp
- arm/unicorn/arm_unicorn.h
constants.cpp
constants.h
core.cpp
@@ -646,7 +644,7 @@ endif()
create_target_directory_groups(core)
target_link_libraries(core PUBLIC common PRIVATE audio_core video_core)
-target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt::fmt nlohmann_json::nlohmann_json mbedtls opus unicorn zip)
+target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt::fmt nlohmann_json::nlohmann_json mbedtls opus zip)
if (YUZU_ENABLE_BOXCAT)
target_compile_definitions(core PRIVATE -DYUZU_ENABLE_BOXCAT)