summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authoramazingfate <liujianfeng1994@gmail.com>2023-11-27 02:25:18 +0100
committerLiam <byteslice@airmail.cc>2023-11-27 02:44:07 +0100
commita76a8fb5fecb4731a9a9231f3e06d5743c34e090 (patch)
tree5b7b163235de2c0ea47b5ea5e698715397fe14d3 /src/core/CMakeLists.txt
parentgeneral: fix mac compile (diff)
downloadyuzu-a76a8fb5fecb4731a9a9231f3e06d5743c34e090.tar
yuzu-a76a8fb5fecb4731a9a9231f3e06d5743c34e090.tar.gz
yuzu-a76a8fb5fecb4731a9a9231f3e06d5743c34e090.tar.bz2
yuzu-a76a8fb5fecb4731a9a9231f3e06d5743c34e090.tar.lz
yuzu-a76a8fb5fecb4731a9a9231f3e06d5743c34e090.tar.xz
yuzu-a76a8fb5fecb4731a9a9231f3e06d5743c34e090.tar.zst
yuzu-a76a8fb5fecb4731a9a9231f3e06d5743c34e090.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index e0bfb5b95..c3ab5ecf9 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -926,8 +926,7 @@ if (ENABLE_WEB_SERVICE)
target_link_libraries(core PRIVATE web_service)
endif()
-if (ARCHITECTURE_arm64 AND (ANDROID OR ${CMAKE_SYSTEM_NAME} STREQUAL "Linux"))
- target_compile_definitions(core PRIVATE -DHAS_NCE)
+if (HAS_NCE)
enable_language(C ASM)
set(CMAKE_ASM_FLAGS "${CFLAGS} -x assembler-with-cpp")