summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2021-02-13 01:21:12 +0100
committerbunnei <bunneidev@gmail.com>2021-02-19 01:16:25 +0100
commit9e520e8f1233cb4e586b076cd5cc8b7c22ec85ce (patch)
tree8a66a3efb40ec4f36374c97e02527010d4034902 /src/core/CMakeLists.txt
parenthle: kernel: Migrate MemoryLayout to KMemoryLayout. (diff)
downloadyuzu-9e520e8f1233cb4e586b076cd5cc8b7c22ec85ce.tar
yuzu-9e520e8f1233cb4e586b076cd5cc8b7c22ec85ce.tar.gz
yuzu-9e520e8f1233cb4e586b076cd5cc8b7c22ec85ce.tar.bz2
yuzu-9e520e8f1233cb4e586b076cd5cc8b7c22ec85ce.tar.lz
yuzu-9e520e8f1233cb4e586b076cd5cc8b7c22ec85ce.tar.xz
yuzu-9e520e8f1233cb4e586b076cd5cc8b7c22ec85ce.tar.zst
yuzu-9e520e8f1233cb4e586b076cd5cc8b7c22ec85ce.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index d12260d9c..a2dce69a7 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -181,6 +181,7 @@ add_library(core STATIC
hle/kernel/k_scoped_scheduler_lock_and_sleep.h
hle/kernel/k_shared_memory.cpp
hle/kernel/k_shared_memory.h
+ hle/kernel/k_slab_heap.h
hle/kernel/k_spin_lock.cpp
hle/kernel/k_spin_lock.h
hle/kernel/k_synchronization_object.cpp
@@ -205,7 +206,6 @@ add_library(core STATIC
hle/kernel/memory/page_heap.h
hle/kernel/memory/page_table.cpp
hle/kernel/memory/page_table.h
- hle/kernel/memory/slab_heap.h
hle/kernel/object.cpp
hle/kernel/object.h
hle/kernel/physical_core.cpp