summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorZach Hilman <zachhilman@gmail.com>2019-05-31 01:35:03 +0200
committerZach Hilman <zachhilman@gmail.com>2019-09-22 03:44:22 +0200
commit7d41c1f52390abb47e67d3fc43310e9d87fbd862 (patch)
tree79a4891115f3efd039b98cc47d63380d811021b1 /src/core/CMakeLists.txt
parentmemory: Port Atmosphere's DmntCheatVm (diff)
downloadyuzu-7d41c1f52390abb47e67d3fc43310e9d87fbd862.tar
yuzu-7d41c1f52390abb47e67d3fc43310e9d87fbd862.tar.gz
yuzu-7d41c1f52390abb47e67d3fc43310e9d87fbd862.tar.bz2
yuzu-7d41c1f52390abb47e67d3fc43310e9d87fbd862.tar.lz
yuzu-7d41c1f52390abb47e67d3fc43310e9d87fbd862.tar.xz
yuzu-7d41c1f52390abb47e67d3fc43310e9d87fbd862.tar.zst
yuzu-7d41c1f52390abb47e67d3fc43310e9d87fbd862.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 877a9e353..a6b56c9c6 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -33,8 +33,6 @@ add_library(core STATIC
file_sys/bis_factory.h
file_sys/card_image.cpp
file_sys/card_image.h
- file_sys/cheat_engine.cpp
- file_sys/cheat_engine.h
file_sys/content_archive.cpp
file_sys/content_archive.h
file_sys/control_metadata.cpp
@@ -477,6 +475,11 @@ add_library(core STATIC
loader/nsp.h
loader/xci.cpp
loader/xci.h
+ memory/cheat_engine.cpp
+ memory/cheat_engine.h
+ memory/dmnt_cheat_types.h
+ memory/dmnt_cheat_vm.cpp
+ memory/dmnt_cheat_vm.h
memory.cpp
memory.h
memory_setup.h