summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorZach Hilman <DarkLordZach@users.noreply.github.com>2018-07-06 16:51:32 +0200
committerbunnei <bunneidev@gmail.com>2018-07-06 16:51:32 +0200
commit77c684c1140f6bf3fb7d4560d06d2efb1a2ee5e2 (patch)
tree38ef6451732c5eecb0efdd198f3db4d33848453c /src/core/CMakeLists.txt
parentMerge pull request #629 from Subv/depth_test (diff)
downloadyuzu-77c684c1140f6bf3fb7d4560d06d2efb1a2ee5e2.tar
yuzu-77c684c1140f6bf3fb7d4560d06d2efb1a2ee5e2.tar.gz
yuzu-77c684c1140f6bf3fb7d4560d06d2efb1a2ee5e2.tar.bz2
yuzu-77c684c1140f6bf3fb7d4560d06d2efb1a2ee5e2.tar.lz
yuzu-77c684c1140f6bf3fb7d4560d06d2efb1a2ee5e2.tar.xz
yuzu-77c684c1140f6bf3fb7d4560d06d2efb1a2ee5e2.tar.zst
yuzu-77c684c1140f6bf3fb7d4560d06d2efb1a2ee5e2.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt18
1 files changed, 8 insertions, 10 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 3dff068df..582294a57 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -8,9 +8,9 @@ add_library(core STATIC
core_cpu.h
core_timing.cpp
core_timing.h
+ file_sys/content_archive.cpp
+ file_sys/content_archive.h
file_sys/directory.h
- file_sys/disk_filesystem.cpp
- file_sys/disk_filesystem.h
file_sys/errors.h
file_sys/filesystem.cpp
file_sys/filesystem.h
@@ -20,15 +20,13 @@ add_library(core STATIC
file_sys/path_parser.h
file_sys/program_metadata.cpp
file_sys/program_metadata.h
- file_sys/romfs_factory.cpp
- file_sys/romfs_factory.h
- file_sys/romfs_filesystem.cpp
- file_sys/romfs_filesystem.h
- file_sys/savedata_factory.cpp
- file_sys/savedata_factory.h
- file_sys/sdmc_factory.cpp
- file_sys/sdmc_factory.h
file_sys/storage.h
+ file_sys/vfs.cpp
+ file_sys/vfs.h
+ file_sys/vfs_offset.cpp
+ file_sys/vfs_offset.h
+ file_sys/vfs_real.cpp
+ file_sys/vfs_real.h
frontend/emu_window.cpp
frontend/emu_window.h
frontend/framebuffer_layout.cpp