summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorMorph <39850852+Morph1984@users.noreply.github.com>2021-09-29 02:53:28 +0200
committerMorph <39850852+Morph1984@users.noreply.github.com>2021-09-29 07:21:35 +0200
commit4acec5283eec3b1a1714981669b605b93910b700 (patch)
tree9eae88748aa1c25f3c96ddd86493d58a2ec2c377 /src/core/CMakeLists.txt
parentexternals: Remove libzip (diff)
downloadyuzu-4acec5283eec3b1a1714981669b605b93910b700.tar
yuzu-4acec5283eec3b1a1714981669b605b93910b700.tar.gz
yuzu-4acec5283eec3b1a1714981669b605b93910b700.tar.bz2
yuzu-4acec5283eec3b1a1714981669b605b93910b700.tar.lz
yuzu-4acec5283eec3b1a1714981669b605b93910b700.tar.xz
yuzu-4acec5283eec3b1a1714981669b605b93910b700.tar.zst
yuzu-4acec5283eec3b1a1714981669b605b93910b700.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt12
1 files changed, 0 insertions, 12 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index a59c5a552..aa3b26628 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -651,13 +651,6 @@ add_library(core STATIC
tools/freezer.h
)
-if (YUZU_ENABLE_BOXCAT)
- target_sources(core PRIVATE
- hle/service/bcat/backend/boxcat.cpp
- hle/service/bcat/backend/boxcat.h
- )
-endif()
-
if (MSVC)
target_compile_options(core PRIVATE
/we4242 # 'identifier': conversion from 'type1' to 'type2', possible loss of data
@@ -690,11 +683,6 @@ create_target_directory_groups(core)
target_link_libraries(core PUBLIC common PRIVATE audio_core video_core)
target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt::fmt nlohmann_json::nlohmann_json mbedtls Opus::Opus)
-if (YUZU_ENABLE_BOXCAT)
- target_compile_definitions(core PRIVATE -DYUZU_ENABLE_BOXCAT)
- target_link_libraries(core PRIVATE httplib nlohmann_json::nlohmann_json)
-endif()
-
if (ENABLE_WEB_SERVICE)
target_compile_definitions(core PRIVATE -DENABLE_WEB_SERVICE)
target_link_libraries(core PRIVATE web_service)