summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorZach Hilman <zachhilman@gmail.com>2019-07-06 00:49:52 +0200
committerZach Hilman <zachhilman@gmail.com>2019-09-22 01:21:22 +0200
commit361a8fa318046e3c333668b3bdb91cbb46eb5639 (patch)
treee121416719a8c9bfbe3ef509319f7b5bd529cbe3 /src/core/CMakeLists.txt
parentUpdate README.md (#2871) (diff)
downloadyuzu-361a8fa318046e3c333668b3bdb91cbb46eb5639.tar
yuzu-361a8fa318046e3c333668b3bdb91cbb46eb5639.tar.gz
yuzu-361a8fa318046e3c333668b3bdb91cbb46eb5639.tar.bz2
yuzu-361a8fa318046e3c333668b3bdb91cbb46eb5639.tar.lz
yuzu-361a8fa318046e3c333668b3bdb91cbb46eb5639.tar.xz
yuzu-361a8fa318046e3c333668b3bdb91cbb46eb5639.tar.zst
yuzu-361a8fa318046e3c333668b3bdb91cbb46eb5639.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 877a9e353..7c142c011 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -70,10 +70,24 @@ add_library(core STATIC
file_sys/sdmc_factory.h
file_sys/submission_package.cpp
file_sys/submission_package.h
+ file_sys/system_archive/data/font_chinese_simplified.cpp
+ file_sys/system_archive/data/font_chinese_simplified.h
+ file_sys/system_archive/data/font_chinese_traditional.cpp
+ file_sys/system_archive/data/font_chinese_traditional.h
+ file_sys/system_archive/data/font_extended_chinese_simplified.cpp
+ file_sys/system_archive/data/font_extended_chinese_simplified.h
+ file_sys/system_archive/data/font_korean.cpp
+ file_sys/system_archive/data/font_korean.h
+ file_sys/system_archive/data/font_nintendo_extended.cpp
+ file_sys/system_archive/data/font_nintendo_extended.h
+ file_sys/system_archive/data/font_standard.cpp
+ file_sys/system_archive/data/font_standard.h
file_sys/system_archive/mii_model.cpp
file_sys/system_archive/mii_model.h
file_sys/system_archive/ng_word.cpp
file_sys/system_archive/ng_word.h
+ file_sys/system_archive/shared_font.cpp
+ file_sys/system_archive/shared_font.h
file_sys/system_archive/system_archive.cpp
file_sys/system_archive/system_archive.h
file_sys/system_archive/system_version.cpp
@@ -495,7 +509,7 @@ add_library(core STATIC
create_target_directory_groups(core)
target_link_libraries(core PUBLIC common PRIVATE audio_core video_core)
-target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt json-headers mbedtls opus unicorn open_source_archives)
+target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt json-headers mbedtls opus unicorn)
if (ENABLE_WEB_SERVICE)
target_compile_definitions(core PRIVATE -DENABLE_WEB_SERVICE)
target_link_libraries(core PRIVATE web_service)