summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorZach Hilman <zachhilman@gmail.com>2019-05-18 03:45:56 +0200
committerZach Hilman <zachhilman@gmail.com>2019-05-25 22:09:20 +0200
commit2dde8f5cfe81648d05d60285ab5b17a6f61c486e (patch)
tree7d9c44658779ad92d66c54069ec1a3fa4d437aed /src/core/CMakeLists.txt
parentqt: Make UI option for 'Reporting Services' temporary (diff)
downloadyuzu-2dde8f5cfe81648d05d60285ab5b17a6f61c486e.tar
yuzu-2dde8f5cfe81648d05d60285ab5b17a6f61c486e.tar.gz
yuzu-2dde8f5cfe81648d05d60285ab5b17a6f61c486e.tar.bz2
yuzu-2dde8f5cfe81648d05d60285ab5b17a6f61c486e.tar.lz
yuzu-2dde8f5cfe81648d05d60285ab5b17a6f61c486e.tar.xz
yuzu-2dde8f5cfe81648d05d60285ab5b17a6f61c486e.tar.zst
yuzu-2dde8f5cfe81648d05d60285ab5b17a6f61c486e.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 2ace866ee..3eacb11b4 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -452,6 +452,8 @@ add_library(core STATIC
memory_setup.h
perf_stats.cpp
perf_stats.h
+ reporter.cpp
+ reporter.h
settings.cpp
settings.h
telemetry_session.cpp
@@ -464,7 +466,7 @@ add_library(core STATIC
create_target_directory_groups(core)
target_link_libraries(core PUBLIC common PRIVATE audio_core video_core)
-target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt mbedtls opus unicorn open_source_archives)
+target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt json-headers mbedtls opus unicorn open_source_archives)
if (ENABLE_WEB_SERVICE)
target_compile_definitions(core PRIVATE -DENABLE_WEB_SERVICE)
target_link_libraries(core PRIVATE web_service)