summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2018-08-04 20:33:11 +0200
committerGitHub <noreply@github.com>2018-08-04 20:33:11 +0200
commit2b06301dbfbfe79687219bf7783a6d1b47695401 (patch)
tree222cc27ecbc7f7e86d2edef8d36436600dee7d7a /src/core/CMakeLists.txt
parentMerge pull request #919 from lioncash/sign (diff)
parentAdd missing parameter to files.push_back() (diff)
downloadyuzu-2b06301dbfbfe79687219bf7783a6d1b47695401.tar
yuzu-2b06301dbfbfe79687219bf7783a6d1b47695401.tar.gz
yuzu-2b06301dbfbfe79687219bf7783a6d1b47695401.tar.bz2
yuzu-2b06301dbfbfe79687219bf7783a6d1b47695401.tar.lz
yuzu-2b06301dbfbfe79687219bf7783a6d1b47695401.tar.xz
yuzu-2b06301dbfbfe79687219bf7783a6d1b47695401.tar.zst
yuzu-2b06301dbfbfe79687219bf7783a6d1b47695401.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 884c28e20..28de22398 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -12,6 +12,16 @@ add_library(core STATIC
core_timing.h
core_timing_util.cpp
core_timing_util.h
+ crypto/aes_util.cpp
+ crypto/aes_util.h
+ crypto/encryption_layer.cpp
+ crypto/encryption_layer.h
+ crypto/key_manager.cpp
+ crypto/key_manager.h
+ crypto/ctr_encryption_layer.cpp
+ crypto/ctr_encryption_layer.h
+ file_sys/card_image.cpp
+ file_sys/card_image.h
file_sys/content_archive.cpp
file_sys/content_archive.h
file_sys/control_metadata.cpp
@@ -327,6 +337,8 @@ add_library(core STATIC
loader/nro.h
loader/nso.cpp
loader/nso.h
+ loader/xci.cpp
+ loader/xci.h
memory.cpp
memory.h
memory_hook.cpp
@@ -346,7 +358,7 @@ add_library(core STATIC
create_target_directory_groups(core)
target_link_libraries(core PUBLIC common PRIVATE audio_core video_core)
-target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt lz4_static opus unicorn)
+target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt lz4_static mbedtls opus unicorn)
if (ARCHITECTURE_x86_64)
target_sources(core PRIVATE