summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2018-01-20 04:34:48 +0100
committerbunnei <bunneidev@gmail.com>2018-01-21 21:39:26 +0100
commit00851a5ef442947c4237f32e063c37e7751db3ed (patch)
treefbdd26c6239a74a89da198f5f807cee81055e0fb /src/core/CMakeLists.txt
parentfile_sys: Remove disk_archive, savedata_archive, and title_metadata. (diff)
downloadyuzu-00851a5ef442947c4237f32e063c37e7751db3ed.tar
yuzu-00851a5ef442947c4237f32e063c37e7751db3ed.tar.gz
yuzu-00851a5ef442947c4237f32e063c37e7751db3ed.tar.bz2
yuzu-00851a5ef442947c4237f32e063c37e7751db3ed.tar.lz
yuzu-00851a5ef442947c4237f32e063c37e7751db3ed.tar.xz
yuzu-00851a5ef442947c4237f32e063c37e7751db3ed.tar.zst
yuzu-00851a5ef442947c4237f32e063c37e7751db3ed.zip
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index b2dcc039a..5ff1311a2 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -6,15 +6,17 @@ add_library(core STATIC
core.h
core_timing.cpp
core_timing.h
- file_sys/archive_backend.cpp
- file_sys/archive_backend.h
- file_sys/directory_backend.h
+ file_sys/directory.h
file_sys/errors.h
- file_sys/file_backend.h
+ file_sys/filesystem.cpp
+ file_sys/filesystem.h
file_sys/path_parser.cpp
file_sys/path_parser.h
- file_sys/romfs_archive.cpp
- file_sys/romfs_archive.h
+ file_sys/romfs_factory.cpp
+ file_sys/romfs_factory.h
+ file_sys/romfs_filesystem.cpp
+ file_sys/romfs_filesystem.h
+ file_sys/storage.h
frontend/emu_window.cpp
frontend/emu_window.h
frontend/framebuffer_layout.cpp