summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <FreddyFunk@users.noreply.github.com>2019-02-08 06:45:50 +0100
committerFreddyFunk <FreddyFunk@users.noreply.github.com>2019-03-29 18:12:42 +0100
commitc791192d649cf01483dbea9907c6d13909b8e5a3 (patch)
tree1b62eaf1f16edfe93ce84c61bed9357d55e1e4e6 /src/common/CMakeLists.txt
parentcore: Do not link LZ4 to core. Use common/data_compression for nso segment decompression instead. (diff)
downloadyuzu-c791192d649cf01483dbea9907c6d13909b8e5a3.tar
yuzu-c791192d649cf01483dbea9907c6d13909b8e5a3.tar.gz
yuzu-c791192d649cf01483dbea9907c6d13909b8e5a3.tar.bz2
yuzu-c791192d649cf01483dbea9907c6d13909b8e5a3.tar.lz
yuzu-c791192d649cf01483dbea9907c6d13909b8e5a3.tar.xz
yuzu-c791192d649cf01483dbea9907c6d13909b8e5a3.tar.zst
yuzu-c791192d649cf01483dbea9907c6d13909b8e5a3.zip
Diffstat (limited to 'src/common/CMakeLists.txt')
-rw-r--r--src/common/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 43834eb85..5639021d3 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -79,8 +79,6 @@ add_library(common STATIC
common_funcs.h
common_paths.h
common_types.h
- data_compression.cpp
- data_compression.h
file_util.cpp
file_util.h
hash.h
@@ -93,6 +91,8 @@ add_library(common STATIC
logging/log.h
logging/text_formatter.cpp
logging/text_formatter.h
+ lz4_compression.cpp
+ lz4_compression.h
math_util.h
memory_hook.cpp
memory_hook.h