summaryrefslogtreecommitdiffstats
path: root/src/citra/CMakeLists.txt
diff options
context:
space:
mode:
authorarchshift <admin@archshift.com>2014-04-29 04:40:39 +0200
committerarchshift <admin@archshift.com>2014-04-29 04:40:39 +0200
commit5a9c2ce5ea1b272d73001acaf9ec15f1c0e5e041 (patch)
treefb68ecea60a4b06ab7142bedc22eb67913a63449 /src/citra/CMakeLists.txt
parentFix complaints about functions that could not be found (diff)
downloadyuzu-5a9c2ce5ea1b272d73001acaf9ec15f1c0e5e041.tar
yuzu-5a9c2ce5ea1b272d73001acaf9ec15f1c0e5e041.tar.gz
yuzu-5a9c2ce5ea1b272d73001acaf9ec15f1c0e5e041.tar.bz2
yuzu-5a9c2ce5ea1b272d73001acaf9ec15f1c0e5e041.tar.lz
yuzu-5a9c2ce5ea1b272d73001acaf9ec15f1c0e5e041.tar.xz
yuzu-5a9c2ce5ea1b272d73001acaf9ec15f1c0e5e041.tar.zst
yuzu-5a9c2ce5ea1b272d73001acaf9ec15f1c0e5e041.zip
Diffstat (limited to 'src/citra/CMakeLists.txt')
-rw-r--r--src/citra/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/citra/CMakeLists.txt b/src/citra/CMakeLists.txt
index 0023da2bf..d7478a2d2 100644
--- a/src/citra/CMakeLists.txt
+++ b/src/citra/CMakeLists.txt
@@ -1,12 +1,14 @@
set(SRCS citra.cpp
emu_window/emu_window_glfw.cpp)
+set(HEADS citra.h
+ resource.h)
# NOTE: This is a workaround for CMake bug 0006976 (missing X11_xf86vmode_LIB variable)
if (NOT X11_xf86vmode_LIB)
set(X11_xv86vmode_LIB Xxf86vm)
endif()
-add_executable(citra ${SRCS})
+add_executable(citra ${SRCS} ${HEADS})
target_link_libraries(citra core common video_core GLEW pthread X11 Xxf86vm Xi ${OPENGL_LIBRARIES} ${GLFW_LIBRARIES} rt ${X11_Xrandr_LIB} ${X11_xv86vmode_LIB})
#install(TARGETS citra RUNTIME DESTINATION ${bindir})