summaryrefslogtreecommitdiffstats
path: root/src/audio_core/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <mathew1800@gmail.com>2020-09-25 06:28:35 +0200
committerLioncash <mathew1800@gmail.com>2020-09-25 07:22:47 +0200
commit8b4ecf22d485958f69ecbd2fa4ca55d9ce393826 (patch)
tree8f920f5ff338f8dcc38fea54c5f3df30c5d35c44 /src/audio_core/CMakeLists.txt
parenteffect_context: Make use of explicit where applicable (diff)
downloadyuzu-8b4ecf22d485958f69ecbd2fa4ca55d9ce393826.tar
yuzu-8b4ecf22d485958f69ecbd2fa4ca55d9ce393826.tar.gz
yuzu-8b4ecf22d485958f69ecbd2fa4ca55d9ce393826.tar.bz2
yuzu-8b4ecf22d485958f69ecbd2fa4ca55d9ce393826.tar.lz
yuzu-8b4ecf22d485958f69ecbd2fa4ca55d9ce393826.tar.xz
yuzu-8b4ecf22d485958f69ecbd2fa4ca55d9ce393826.tar.zst
yuzu-8b4ecf22d485958f69ecbd2fa4ca55d9ce393826.zip
Diffstat (limited to 'src/audio_core/CMakeLists.txt')
-rw-r--r--src/audio_core/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/audio_core/CMakeLists.txt b/src/audio_core/CMakeLists.txt
index cb00ef60e..6a7075f73 100644
--- a/src/audio_core/CMakeLists.txt
+++ b/src/audio_core/CMakeLists.txt
@@ -44,6 +44,16 @@ add_library(audio_core STATIC
create_target_directory_groups(audio_core)
+if (NOT MSVC)
+ target_compile_options(audio_core PRIVATE
+ -Werror=ignored-qualifiers
+ -Werror=implicit-fallthrough
+ -Werror=reorder
+ -Werror=sign-compare
+ -Werror=unused-variable
+ )
+endif()
+
target_link_libraries(audio_core PUBLIC common core)
target_link_libraries(audio_core PRIVATE SoundTouch)