summaryrefslogtreecommitdiffstats
path: root/src/audio_core/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2022-12-03 20:10:06 +0100
committerGitHub <noreply@github.com>2022-12-03 20:10:06 +0100
commit75e16547f8977e8b2b07723b04bcc3cbe999d566 (patch)
tree7a7795d68f636d1a3f4972c3ea36c1d50db564c5 /src/audio_core/CMakeLists.txt
parentMerge pull request #9289 from liamwhite/fruit-company (diff)
parentCMake: Consolidate common PCH headers (diff)
downloadyuzu-75e16547f8977e8b2b07723b04bcc3cbe999d566.tar
yuzu-75e16547f8977e8b2b07723b04bcc3cbe999d566.tar.gz
yuzu-75e16547f8977e8b2b07723b04bcc3cbe999d566.tar.bz2
yuzu-75e16547f8977e8b2b07723b04bcc3cbe999d566.tar.lz
yuzu-75e16547f8977e8b2b07723b04bcc3cbe999d566.tar.xz
yuzu-75e16547f8977e8b2b07723b04bcc3cbe999d566.tar.zst
yuzu-75e16547f8977e8b2b07723b04bcc3cbe999d566.zip
Diffstat (limited to 'src/audio_core/CMakeLists.txt')
-rw-r--r--src/audio_core/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/audio_core/CMakeLists.txt b/src/audio_core/CMakeLists.txt
index 75416c53a..0a9d9ec29 100644
--- a/src/audio_core/CMakeLists.txt
+++ b/src/audio_core/CMakeLists.txt
@@ -31,6 +31,7 @@ add_library(audio_core STATIC
out/audio_out.h
out/audio_out_system.cpp
out/audio_out_system.h
+ precompiled_headers.h
renderer/adsp/adsp.cpp
renderer/adsp/adsp.h
renderer/adsp/audio_renderer.cpp
@@ -233,3 +234,7 @@ if(ENABLE_SDL2)
endif()
target_compile_definitions(audio_core PRIVATE HAVE_SDL2)
endif()
+
+if (YUZU_USE_PRECOMPILED_HEADERS)
+ target_precompile_headers(audio_core PRIVATE precompiled_headers.h)
+endif()