summaryrefslogtreecommitdiffstats
path: root/src/audio_core/CMakeLists.txt
diff options
context:
space:
mode:
authorKAMiKAZOW <kamikazow@web.de>2018-08-07 13:21:56 +0200
committerGitHub <noreply@github.com>2018-08-07 13:21:56 +0200
commit0f5c4615ae4aa0c2f83a3584c74ee9f2a0126f9f (patch)
tree06c32d0a34a5276c9ebfe93096acb5498f2cab71 /src/audio_core/CMakeLists.txt
parentMerge pull request #931 from DarkLordZach/nca-as-drd (diff)
downloadyuzu-0f5c4615ae4aa0c2f83a3584c74ee9f2a0126f9f.tar
yuzu-0f5c4615ae4aa0c2f83a3584c74ee9f2a0126f9f.tar.gz
yuzu-0f5c4615ae4aa0c2f83a3584c74ee9f2a0126f9f.tar.bz2
yuzu-0f5c4615ae4aa0c2f83a3584c74ee9f2a0126f9f.tar.lz
yuzu-0f5c4615ae4aa0c2f83a3584c74ee9f2a0126f9f.tar.xz
yuzu-0f5c4615ae4aa0c2f83a3584c74ee9f2a0126f9f.tar.zst
yuzu-0f5c4615ae4aa0c2f83a3584c74ee9f2a0126f9f.zip
Diffstat (limited to '')
-rw-r--r--src/audio_core/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/audio_core/CMakeLists.txt b/src/audio_core/CMakeLists.txt
index 827ab0ac7..ec71524a3 100644
--- a/src/audio_core/CMakeLists.txt
+++ b/src/audio_core/CMakeLists.txt
@@ -4,8 +4,6 @@ add_library(audio_core STATIC
audio_renderer.cpp
audio_renderer.h
buffer.h
- cubeb_sink.cpp
- cubeb_sink.h
codec.cpp
codec.h
null_sink.h
@@ -15,6 +13,8 @@ add_library(audio_core STATIC
sink_details.cpp
sink_details.h
sink_stream.h
+
+ $<$<BOOL:${ENABLE_CUBEB}>:cubeb_sink.cpp cubeb_sink.h>
)
create_target_directory_groups(audio_core)