summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2019-05-09 19:23:49 +0200
committerGitHub <noreply@github.com>2019-05-09 19:23:49 +0200
commitf3317cf2db4c4f2248053e67dbe9ac27c89972d2 (patch)
tree5da8bc013ea6739a41568ea8dca09b30f2284f92 /src/CMakeLists.txt
parentMerge pull request #2442 from FernandoS27/astc-fix (diff)
parentsrc/CMakeLists: Add /Zc:externConstexpr to the MSVC build flags (diff)
downloadyuzu-f3317cf2db4c4f2248053e67dbe9ac27c89972d2.tar
yuzu-f3317cf2db4c4f2248053e67dbe9ac27c89972d2.tar.gz
yuzu-f3317cf2db4c4f2248053e67dbe9ac27c89972d2.tar.bz2
yuzu-f3317cf2db4c4f2248053e67dbe9ac27c89972d2.tar.lz
yuzu-f3317cf2db4c4f2248053e67dbe9ac27c89972d2.tar.xz
yuzu-f3317cf2db4c4f2248053e67dbe9ac27c89972d2.tar.zst
yuzu-f3317cf2db4c4f2248053e67dbe9ac27c89972d2.zip
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt30
1 files changed, 21 insertions, 9 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9aea4af87..a1d87bbbc 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -21,15 +21,27 @@ if (MSVC)
# Ensure that projects build with Unicode support.
add_definitions(-DUNICODE -D_UNICODE)
- # /W3 - Level 3 warnings
- # /MP - Multi-threaded compilation
- # /Zi - Output debugging information
- # /Zo - enhanced debug info for optimized builds
- # /permissive- - enables stricter C++ standards conformance checks
- # /EHsc - C++-only exception handling semantics
- # /Zc:throwingNew - let codegen assume `operator new` will never return null
- # /Zc:inline - let codegen omit inline functions in object files
- add_compile_options(/W3 /MP /Zi /Zo /permissive- /EHsc /std:c++latest /Zc:throwingNew,inline)
+ # /W3 - Level 3 warnings
+ # /MP - Multi-threaded compilation
+ # /Zi - Output debugging information
+ # /Zo - Enhanced debug info for optimized builds
+ # /permissive- - Enables stricter C++ standards conformance checks
+ # /EHsc - C++-only exception handling semantics
+ # /Zc:externConstexpr - Allow extern constexpr variables to have external linkage, like the standard mandates
+ # /Zc:inline - Let codegen omit inline functions in object files
+ # /Zc:throwingNew - Let codegen assume `operator new` (without std::nothrow) will never return null
+ add_compile_options(
+ /W3
+ /MP
+ /Zi
+ /Zo
+ /permissive-
+ /EHsc
+ /std:c++latest
+ /Zc:externConstexpr
+ /Zc:inline
+ /Zc:throwingNew
+ )
# /GS- - No stack buffer overflow checks
add_compile_options("$<$<CONFIG:Release>:/GS->")