summaryrefslogtreecommitdiffstats
path: root/externals/open_source_archives/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <mathew1800@gmail.com>2018-09-11 10:15:36 +0200
committerLioncash <mathew1800@gmail.com>2018-09-11 10:25:33 +0200
commit46ba1bc40f110a52292290634eefd0c030677eea (patch)
tree082e212263ed4b2409b2fe62faa4cd3b6a051e8d /externals/open_source_archives/CMakeLists.txt
parentUse open-source shared fonts if no dumped file is available (#1269) (diff)
downloadyuzu-46ba1bc40f110a52292290634eefd0c030677eea.tar
yuzu-46ba1bc40f110a52292290634eefd0c030677eea.tar.gz
yuzu-46ba1bc40f110a52292290634eefd0c030677eea.tar.bz2
yuzu-46ba1bc40f110a52292290634eefd0c030677eea.tar.lz
yuzu-46ba1bc40f110a52292290634eefd0c030677eea.tar.xz
yuzu-46ba1bc40f110a52292290634eefd0c030677eea.tar.zst
yuzu-46ba1bc40f110a52292290634eefd0c030677eea.zip
Diffstat (limited to 'externals/open_source_archives/CMakeLists.txt')
-rw-r--r--externals/open_source_archives/CMakeLists.txt17
1 files changed, 15 insertions, 2 deletions
diff --git a/externals/open_source_archives/CMakeLists.txt b/externals/open_source_archives/CMakeLists.txt
index 0b2397203..d1e4bdbe6 100644
--- a/externals/open_source_archives/CMakeLists.txt
+++ b/externals/open_source_archives/CMakeLists.txt
@@ -1,3 +1,16 @@
-add_library(open_source_archives INTERFACE)
+add_library(open_source_archives
+ src/FontChineseSimplified.cpp
+ src/FontChineseTraditional.cpp
+ src/FontExtendedChineseSimplified.cpp
+ src/FontKorean.cpp
+ src/FontNintendoExtended.cpp
+ src/FontStandard.cpp
+ include/FontChineseSimplified.h
+ include/FontChineseTraditional.h
+ include/FontExtendedChineseSimplified.h
+ include/FontKorean.h
+ include/FontNintendoExtended.h
+ include/FontStandard.h
+)
-target_include_directories(open_source_archives INTERFACE "include/")
+target_include_directories(open_source_archives PUBLIC include)