summaryrefslogtreecommitdiffstats
path: root/externals/libusb/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2023-10-30 20:32:31 +0100
committerGitHub <noreply@github.com>2023-10-30 20:32:31 +0100
commit22cac3a5e342e4a98d87c113b2d95b84cb5aa826 (patch)
treeae3d6c6caaae42739b0ff957593a86ba5627c040 /externals/libusb/CMakeLists.txt
parentMerge pull request #11908 from t895/log-spam (diff)
parentexternals/opus: use CMakeLists shipped with Opus itself (diff)
downloadyuzu-22cac3a5e342e4a98d87c113b2d95b84cb5aa826.tar
yuzu-22cac3a5e342e4a98d87c113b2d95b84cb5aa826.tar.gz
yuzu-22cac3a5e342e4a98d87c113b2d95b84cb5aa826.tar.bz2
yuzu-22cac3a5e342e4a98d87c113b2d95b84cb5aa826.tar.lz
yuzu-22cac3a5e342e4a98d87c113b2d95b84cb5aa826.tar.xz
yuzu-22cac3a5e342e4a98d87c113b2d95b84cb5aa826.tar.zst
yuzu-22cac3a5e342e4a98d87c113b2d95b84cb5aa826.zip
Diffstat (limited to 'externals/libusb/CMakeLists.txt')
-rw-r--r--externals/libusb/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/externals/libusb/CMakeLists.txt b/externals/libusb/CMakeLists.txt
index 6757b59da..1d50c9f8c 100644
--- a/externals/libusb/CMakeLists.txt
+++ b/externals/libusb/CMakeLists.txt
@@ -49,11 +49,6 @@ if (MINGW OR (${CMAKE_SYSTEM_NAME} MATCHES "Linux") OR APPLE)
set(LIBUSB_INCLUDE_DIRS "${LIBUSB_SRC_DIR}/libusb" CACHE PATH "libusb headers path" FORCE)
- # MINGW: causes "externals/libusb/libusb/libusb/os/windows_winusb.c:1427:2: error: conversion to non-scalar type requested", so cannot statically link it for now.
- if (NOT MINGW)
- set(LIBUSB_CFLAGS "-DGUID_DEVINTERFACE_USB_DEVICE=\\(GUID\\){0xA5DCBF10,0x6530,0x11D2,{0x90,0x1F,0x00,0xC0,0x4F,0xB9,0x51,0xED}}")
- endif()
-
make_directory("${LIBUSB_PREFIX}")
add_custom_command(
@@ -146,8 +141,6 @@ else() # MINGW OR (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
target_include_directories(usb BEFORE PRIVATE libusb/msvc)
endif()
- # Works around other libraries providing their own definition of USB GUIDs (e.g. SDL2)
- target_compile_definitions(usb PRIVATE "-DGUID_DEVINTERFACE_USB_DEVICE=(GUID){ 0xA5DCBF10, 0x6530, 0x11D2, {0x90, 0x1F, 0x00, 0xC0, 0x4F, 0xB9, 0x51, 0xED}}")
else()
target_include_directories(usb
# turns out other projects also have "config.h", so make sure the