summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorWeiyi Wang <wwylele@gmail.com>2018-10-16 19:23:07 +0200
committerfearlessTobi <thm.frey@gmail.com>2018-10-23 15:11:25 +0200
commitd9ca6351dd82ad644b6cbdbb8184c9b90bbfa9ed (patch)
tree5961be9e6676643384b7ee813fdacb2f5c21de2a /CMakeLists.txt
parentonly redefine 64 bit file operation for MSVC (diff)
downloadyuzu-d9ca6351dd82ad644b6cbdbb8184c9b90bbfa9ed.tar
yuzu-d9ca6351dd82ad644b6cbdbb8184c9b90bbfa9ed.tar.gz
yuzu-d9ca6351dd82ad644b6cbdbb8184c9b90bbfa9ed.tar.bz2
yuzu-d9ca6351dd82ad644b6cbdbb8184c9b90bbfa9ed.tar.lz
yuzu-d9ca6351dd82ad644b6cbdbb8184c9b90bbfa9ed.tar.xz
yuzu-d9ca6351dd82ad644b6cbdbb8184c9b90bbfa9ed.tar.zst
yuzu-d9ca6351dd82ad644b6cbdbb8184c9b90bbfa9ed.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6021a8054..6e98b557e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -170,7 +170,7 @@ endif()
# On modern Unixes, this is typically already the case. The lone exception is
# glibc, which may default to 32 bits. glibc allows this to be configured
# by setting _FILE_OFFSET_BITS.
-if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
+if(CMAKE_SYSTEM_NAME STREQUAL "Linux" OR MINGW)
add_definitions(-D_FILE_OFFSET_BITS=64)
endif()