summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2014-10-08 01:44:13 +0200
committerbunnei <bunneidev@gmail.com>2014-10-08 01:44:13 +0200
commita171000cbec1dbae4e5c0c34ea1d7ef1b4313164 (patch)
treea6bc766749aabd4eb8df276749fe51db49ee7030 /CMakeLists.txt
parentMerge pull request #129 from linkmauve/master (diff)
parentAdded configuration file system. (diff)
downloadyuzu-a171000cbec1dbae4e5c0c34ea1d7ef1b4313164.tar
yuzu-a171000cbec1dbae4e5c0c34ea1d7ef1b4313164.tar.gz
yuzu-a171000cbec1dbae4e5c0c34ea1d7ef1b4313164.tar.bz2
yuzu-a171000cbec1dbae4e5c0c34ea1d7ef1b4313164.tar.lz
yuzu-a171000cbec1dbae4e5c0c34ea1d7ef1b4313164.tar.xz
yuzu-a171000cbec1dbae4e5c0c34ea1d7ef1b4313164.tar.zst
yuzu-a171000cbec1dbae4e5c0c34ea1d7ef1b4313164.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83b0863f9..bbe9f76cd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -68,7 +68,7 @@ if (ENABLE_GLFW)
if (NOT APPLE)
find_package(X11 REQUIRED)
endif()
-
+
find_package(PkgConfig REQUIRED)
pkg_search_module(GLFW REQUIRED glfw3)
endif()
@@ -127,6 +127,10 @@ get_git_head_revision(GIT_REF_SPEC GIT_REV)
git_describe(GIT_DESC --always --long --dirty)
git_branch_name(GIT_BRANCH)
+set(INI_PREFIX "${CMAKE_CURRENT_SOURCE_DIR}/externals/inih")
+include_directories(${INI_PREFIX})
+add_subdirectory(${INI_PREFIX})
+
# process subdirectories
if(ENABLE_QT)
include_directories(externals/qhexedit)