summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrederic L <frederic.laing.development@gmail.com>2019-06-20 04:26:12 +0200
committerbunnei <bunneidev@gmail.com>2019-06-20 04:26:12 +0200
commit5cef446f42e698a524c6c3240fedb0031f8e5694 (patch)
treeefefc9c889a14bba9f47e72f1bb83a44f0679e68 /CMakeLists.txt
parentMerge pull request #2594 from FearlessTobi/very-important-change (diff)
downloadyuzu-5cef446f42e698a524c6c3240fedb0031f8e5694.tar
yuzu-5cef446f42e698a524c6c3240fedb0031f8e5694.tar.gz
yuzu-5cef446f42e698a524c6c3240fedb0031f8e5694.tar.bz2
yuzu-5cef446f42e698a524c6c3240fedb0031f8e5694.tar.lz
yuzu-5cef446f42e698a524c6c3240fedb0031f8e5694.tar.xz
yuzu-5cef446f42e698a524c6c3240fedb0031f8e5694.tar.zst
yuzu-5cef446f42e698a524c6c3240fedb0031f8e5694.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt28
1 files changed, 12 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bfa104034..9a207f9e3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,18 @@ include(CMakeDependentOption)
project(yuzu)
+# Get Git submodule dependencies
+find_package(Git QUIET)
+if(GIT_FOUND AND EXISTS "${PROJECT_SOURCE_DIR}/.git")
+ execute_process(COMMAND ${GIT_EXECUTABLE} submodule update --init --recursive
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ RESULT_VARIABLE GIT_SUBMOD_RESULT)
+ if(NOT GIT_SUBMOD_RESULT EQUAL "0")
+ message(FATAL_ERROR "git submodule update --init --recursive failed with ${GIT_SUBMOD_RESULT}, "
+ "please checkout submodules manually with \"git submodule update --init --recursive\"")
+ endif()
+endif()
+
# Set bundled sdl2/qt as dependent options.
# OFF by default, but if ENABLE_SDL2 and MSVC are true then ON
option(ENABLE_SDL2 "Enable the SDL2 frontend" ON)
@@ -33,22 +45,6 @@ if(NOT EXISTS ${PROJECT_SOURCE_DIR}/.git/hooks/pre-commit)
DESTINATION ${PROJECT_SOURCE_DIR}/.git/hooks)
endif()
-# Sanity check : Check that all submodules are present
-# =======================================================================
-
-function(check_submodules_present)
- file(READ "${PROJECT_SOURCE_DIR}/.gitmodules" gitmodules)
- string(REGEX MATCHALL "path *= *[^ \t\r\n]*" gitmodules ${gitmodules})
- foreach(module ${gitmodules})
- string(REGEX REPLACE "path *= *" "" module ${module})
- if (NOT EXISTS "${PROJECT_SOURCE_DIR}/${module}/.git")
- message(FATAL_ERROR "Git submodule ${module} not found. "
- "Please run: git submodule update --init --recursive")
- endif()
- endforeach()
-endfunction()
-check_submodules_present()
-
configure_file(${PROJECT_SOURCE_DIR}/dist/compatibility_list/compatibility_list.qrc
${PROJECT_BINARY_DIR}/dist/compatibility_list/compatibility_list.qrc
COPYONLY)