summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTony Wasserka <neobrainx@gmail.com>2014-12-12 17:32:57 +0100
committerTony Wasserka <neobrainx@gmail.com>2014-12-12 17:32:57 +0100
commit33e61ef514d2b1a32eea10161d900f1e2e5c0ba2 (patch)
treed4f7e432ab42cf7fad3834bb14ba72b54b346cc0 /CMakeLists.txt
parentMerge pull request #268 from bunnei/dsp-read-pipe-if-possible (diff)
parentStringUtil: Perform some minimal cleanup. (diff)
downloadyuzu-33e61ef514d2b1a32eea10161d900f1e2e5c0ba2.tar
yuzu-33e61ef514d2b1a32eea10161d900f1e2e5c0ba2.tar.gz
yuzu-33e61ef514d2b1a32eea10161d900f1e2e5c0ba2.tar.bz2
yuzu-33e61ef514d2b1a32eea10161d900f1e2e5c0ba2.tar.lz
yuzu-33e61ef514d2b1a32eea10161d900f1e2e5c0ba2.tar.xz
yuzu-33e61ef514d2b1a32eea10161d900f1e2e5c0ba2.tar.zst
yuzu-33e61ef514d2b1a32eea10161d900f1e2e5c0ba2.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 05a560404..61d5d524a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,14 @@ if (PNG_FOUND)
add_definitions(-DHAVE_PNG)
endif ()
+find_package(Boost)
+if (Boost_FOUND)
+ include_directories(${Boost_INCLUDE_DIRS})
+else()
+ message(STATUS "Boost not found, falling back to externals")
+ include_directories(externals/boost)
+endif()
+
# Include bundled CMake modules
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/externals/cmake-modules")