summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorwithmorten <morten.with@gmail.com>2021-02-02 14:02:42 +0100
committerwithmorten <morten.with@gmail.com>2021-02-02 14:27:21 +0100
commitef28d12d85d65009f1b7f34dd1368a28eaa103ec (patch)
treeeb92fb9e77fb2ca5f7aa7a4c6fb79bdd80d4c4f1 /src/CMakeLists.txt
parentadd w to CVector; adjust col structs a bit (diff)
downloadre3-ef28d12d85d65009f1b7f34dd1368a28eaa103ec.tar
re3-ef28d12d85d65009f1b7f34dd1368a28eaa103ec.tar.gz
re3-ef28d12d85d65009f1b7f34dd1368a28eaa103ec.tar.bz2
re3-ef28d12d85d65009f1b7f34dd1368a28eaa103ec.tar.lz
re3-ef28d12d85d65009f1b7f34dd1368a28eaa103ec.tar.xz
re3-ef28d12d85d65009f1b7f34dd1368a28eaa103ec.tar.zst
re3-ef28d12d85d65009f1b7f34dd1368a28eaa103ec.zip
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f3d51b06..8325938c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -102,6 +102,8 @@ if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU" OR CMAKE_CXX_COMPILER_ID STREQUAL "Clang
if (NOT LIBRW_PLATFORM_PS2)
target_compile_options(${EXECUTABLE}
PRIVATE
+ -fpermissive # for CVECTORHACK
+ -Wno-address-of-temporary # for CVECTORHACK
-Wextra
-Wdouble-promotion
-Wpedantic