summaryrefslogtreecommitdiffstats
path: root/src/HTTPServer/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2015-12-25 19:42:50 +0100
committerMattes D <github@xoft.cz>2016-03-01 16:19:55 +0100
commit2dbc54a14824329faf53851441c6585fd451f0a2 (patch)
treebd59ed0139bfa7aff6a337c45cc38446e8812387 /src/HTTPServer/CMakeLists.txt
parentMerge pull request #3057 from tonibm19/master (diff)
downloadcuberite-2dbc54a14824329faf53851441c6585fd451f0a2.tar
cuberite-2dbc54a14824329faf53851441c6585fd451f0a2.tar.gz
cuberite-2dbc54a14824329faf53851441c6585fd451f0a2.tar.bz2
cuberite-2dbc54a14824329faf53851441c6585fd451f0a2.tar.lz
cuberite-2dbc54a14824329faf53851441c6585fd451f0a2.tar.xz
cuberite-2dbc54a14824329faf53851441c6585fd451f0a2.tar.zst
cuberite-2dbc54a14824329faf53851441c6585fd451f0a2.zip
Diffstat (limited to 'src/HTTPServer/CMakeLists.txt')
-rw-r--r--src/HTTPServer/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/HTTPServer/CMakeLists.txt b/src/HTTPServer/CMakeLists.txt
index a08a1fcf8..e8026f761 100644
--- a/src/HTTPServer/CMakeLists.txt
+++ b/src/HTTPServer/CMakeLists.txt
@@ -6,31 +6,31 @@ include_directories ("${PROJECT_SOURCE_DIR}/../")
SET (SRCS
EnvelopeParser.cpp
- HTTPConnection.cpp
HTTPFormParser.cpp
HTTPMessage.cpp
HTTPServer.cpp
+ HTTPServerConnection.cpp
MultipartParser.cpp
NameValueParser.cpp
- SslHTTPConnection.cpp
+ SslHTTPServerConnection.cpp
UrlParser.cpp
)
SET (HDRS
EnvelopeParser.h
- HTTPConnection.h
HTTPFormParser.h
HTTPMessage.h
HTTPServer.h
+ HTTPServerConnection.h
MultipartParser.h
NameValueParser.h
- SslHTTPConnection.h
+ SslHTTPServerConnection.h
UrlParser.h
)
if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
set_source_files_properties(HTTPServer.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=global-constructors ")
- set_source_files_properties(HTTPConnection.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=switch-enum")
+ set_source_files_properties(HTTPServerConnection.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=switch-enum")
set_source_files_properties(HTTPMessage.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=tautological-compare")
endif()