summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorpeterbell10 <peterbell10@live.co.uk>2018-08-29 02:51:25 +0200
committerGitHub <noreply@github.com>2018-08-29 02:51:25 +0200
commitee8419701472be9f24c51a41ee7b7ef3cf38f329 (patch)
treeb689d4657ec4bb2de7e47f43f670e99b564f85a7 /src/CMakeLists.txt
parentStore and pass entity effect duration as an int not a short. (#4293) (diff)
downloadcuberite-ee8419701472be9f24c51a41ee7b7ef3cf38f329.tar
cuberite-ee8419701472be9f24c51a41ee7b7ef3cf38f329.tar.gz
cuberite-ee8419701472be9f24c51a41ee7b7ef3cf38f329.tar.bz2
cuberite-ee8419701472be9f24c51a41ee7b7ef3cf38f329.tar.lz
cuberite-ee8419701472be9f24c51a41ee7b7ef3cf38f329.tar.xz
cuberite-ee8419701472be9f24c51a41ee7b7ef3cf38f329.tar.zst
cuberite-ee8419701472be9f24c51a41ee7b7ef3cf38f329.zip
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 642bc81a3..e895b1657 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -159,7 +159,10 @@ SET (HDRS
XMLParser.h
)
-include_directories(".")
+file(WRITE "${CMAKE_BINARY_DIR}/include/Globals.h"
+ "/* This file allows Globals.h to be included with an absolute path */\n#include \"${PROJECT_SOURCE_DIR}/Globals.h\"\n")
+
+include_directories("${CMAKE_BINARY_DIR}/include")
include_directories ("${CMAKE_CURRENT_SOURCE_DIR}/../lib/sqlite")
include_directories ("${CMAKE_CURRENT_SOURCE_DIR}/../lib/SQLiteCpp/include")
include_directories (SYSTEM "${CMAKE_CURRENT_SOURCE_DIR}/../lib/TCLAP/include")
@@ -245,8 +248,6 @@ else ()
includefolder("Resources")
source_group("" FILES ${SOURCE})
- include_directories("${PROJECT_SOURCE_DIR}")
-
# Precompiled headers (1st part)
SET_SOURCE_FILES_PROPERTIES(
Globals.cpp PROPERTIES COMPILE_FLAGS "/Yc\"Globals.h\""