summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Harkness <me@bearbin.net>2020-08-06 18:13:47 +0200
committerGitHub <noreply@github.com>2020-08-06 18:13:47 +0200
commitfd52d8e8df2e8e23f7c308175a7151290f086458 (patch)
treef6d05bce38bb66c7cd99bc7863742d86242fa468 /CMakeLists.txt
parentRevert "Hotpatch optional for macOSX builds on buildserver" (diff)
downloadcuberite-fd52d8e8df2e8e23f7c308175a7151290f086458.tar
cuberite-fd52d8e8df2e8e23f7c308175a7151290f086458.tar.gz
cuberite-fd52d8e8df2e8e23f7c308175a7151290f086458.tar.bz2
cuberite-fd52d8e8df2e8e23f7c308175a7151290f086458.tar.lz
cuberite-fd52d8e8df2e8e23f7c308175a7151290f086458.tar.xz
cuberite-fd52d8e8df2e8e23f7c308175a7151290f086458.tar.zst
cuberite-fd52d8e8df2e8e23f7c308175a7151290f086458.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 8 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 077a411a5..a602d268a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,11 +3,14 @@
# Use CMake to generate the build files for your platform
#
# This script supports some configuration through CMake arguments (-Dparam=val syntax):
-# BUILD_TOOLS=1 sets up additional executables to be built along with the server (ProtoProxy, GrownBiomeGenVisualiser, MCADefrag)
-# BUILD_UNSTABLE_TOOLS=1 sets up yet more executables to be built, these can be broken and generally are obsolete (GeneratorPerformanceTest)
-# NO_NATIVE_OPTIMIZATION=1 disables CPU-specific optimisations for the current machine, allows use on other CPUs of the same platform
-# DISABLE_SYSTEM_LUA=1 disables the use of system Lua interpreter; the tolua executable will be built and used instead. Incompatible with cross-compiling
-# SELF_TEST=1 enables testing code to be built
+# BUILD_TOOLS=1 sets up additional executables to be built along with the server (ProtoProxy, GrownBiomeGenVisualiser, MCADefrag)
+# BUILD_UNSTABLE_TOOLS=1 sets up yet more executables to be built, these can be broken and generally are obsolete (GeneratorPerformanceTest)
+# NO_NATIVE_OPTIMIZATION=1 disables CPU-specific optimisations for the current machine, allows use on other CPUs of the same platform
+# DISABLE_SYSTEM_LUA=1 disables the use of system Lua interpreter; the tolua executable will be built and used instead. Incompatible with cross-compiling
+# SELF_TEST=1 enables testing code to be built
+# UNITY_BUILDS=OFF disables unity builds
+# PRECOMPILE_HEADERS=OFF disables precompiled headers
+# WHOLE_PROGRAM_OPTIMISATION=OFF disables link time optimisation