summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTycho <work.tycho+git@gmail.com>2014-02-05 19:10:45 +0100
committerTycho <work.tycho+git@gmail.com>2014-02-05 19:10:45 +0100
commitf25597540de890f48a0b4df6feeb7e4c3246efb8 (patch)
tree0921b5d935743f2180f1a32b91645f3bcc6e6c95 /CMakeLists.txt
parentAdded Self Test Plugin (diff)
downloadcuberite-f25597540de890f48a0b4df6feeb7e4c3246efb8.tar
cuberite-f25597540de890f48a0b4df6feeb7e4c3246efb8.tar.gz
cuberite-f25597540de890f48a0b4df6feeb7e4c3246efb8.tar.bz2
cuberite-f25597540de890f48a0b4df6feeb7e4c3246efb8.tar.lz
cuberite-f25597540de890f48a0b4df6feeb7e4c3246efb8.tar.xz
cuberite-f25597540de890f48a0b4df6feeb7e4c3246efb8.tar.zst
cuberite-f25597540de890f48a0b4df6feeb7e4c3246efb8.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1fee887e7..57b200a2a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -124,6 +124,10 @@ endif()
# The Expat library is linked in statically, make the source files aware of that:
add_definitions(-DXML_STATIC)
+# Self Test Mode enables extra checks at startup
+if(${SELF_TEST})
+ add_definitions(-DSELF_TEST)
+endif()
# Declare the flags used for profiling builds:
if (MSVC)